powered by Jive Software

Java heap size not changing

I have followed the instructions listed in multiple threads but I cannot get the heap size to increase and the server is still showing as only 256mb for the heap.

Openfire 4.2.3 (32bit) running as a service on Windows 2012 64bit

added the xmpp.pep.enabled with a value of false to the System Properties screen in the openfire admin console.

created openfire-service.vmoptions to the Program Files (x86)\Openfire\bin folder.
Only line in the file is INSTALL4J_ADD_VM_PARAMS="-Xms512m -Xmx1024m"

Restarted service multiple times, to no avail. The heap is still only 256 and staying at 99% full crashing our system constantly.

Well, it should be only xms and xmx with values. Read the custom parameters part http://download.igniterealtime.org/openfire/docs/latest/documentation/install-guide.html

I tried it with just the xms and xmx values and the service would not start.

Just tried it on my test server and it worked (the max value changed). Granted, my Openfire is installed in C:\Openfire to avoid problems with UAC protection. It might be that your changes to vmoptions file are not actually saved into Programs files folder, but to a virtual store folder. Windows does that to protect Program files from altering by malware. Check if your changes are not actually saved in C:\Users\user\AppData\Local\VirtualStore\Program Files (x86)\Openfire\bin\

You may also try opening Notepad via Run as administrator (even if you are logged in with local admin) and then open vmoptions file via File > Open and edit it.

You can also attach your vmoptions file here or post it contents into some Paste service and give a link here.

Finally got it to update.

I was using the Windows Service.msc to bounce the Openfire service. When I used the openfire-service.exe /start it read the vmoptions file correctly.

thanks for the help.

Strange. It should have worked via Services. I was stopping and starting it via msc. I only use that exe to install or uninstall the service.

I couldn’t get it to take effect either; Pak_K suggested that they had to manually run openfire-service.exe /start in a command prompt for theirs to take effect which might have worked for me but I’d already uninstalled the service by that point so I first had to reinstall the service (run it with /install) – with the openfire-service.vmoptions file in the bin folder. It works now. So for anyone else like me out there trying stuff, if none of the rest of it works, try that combination in order for it to take effect: uninstall the service, reinstall it with the mod file in there.