trying to login after 3.9.3 upgrade

Did the upgrade from 3.9.2 to 3.9.3 and after trying to login to web admin using my LDAP username I get the following error everytime (all browsers):


Problem accessing /index.jsp. Reason:

**Caused by: **



at org.jivesoftware.openfire.clearspace.SSLProtocolSocketFactory.createSSLContext(

at org.jivesoftware.openfire.clearspace.SSLProtocolSocketFactory.getSSLContext(SSL

at org.jivesoftware.openfire.clearspace.SSLProtocolSocketFactory.createSocket(SSLP


at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDir

at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirect

at org.apache.commons.httpclient.HttpClient.executeMethod(

at org.apache.commons.httpclient.HttpClient.executeMethod(

at org.jivesoftware.util.HttpClientWithTimeoutFeedFetcher.retrieveFeed(HttpClientW

at org.jivesoftware.openfire.admin.index_jsp._jspService( at org.apache.jasper.runtime.HttpJspBase.service( at javax.servlet.http.HttpServlet.service( at org.eclipse.jetty.servlet.ServletHolder.handle(

at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1359)

at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage( 8)

at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(

at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1330)

at org.jivesoftware.util.LocaleFilter.doFilter(

at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1330)

at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF

at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1330)

at org.jivesoftware.admin.PluginFilter.doFilter(

at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1330)

at org.jivesoftware.admin.AuthCheckFilter.doFilter(

at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1330)

at org.eclipse.jetty.servlet.ServletHandler.doHandle(

at org.eclipse.jetty.server.handler.ScopedHandler.handle(


at org.eclipse.jetty.server.session.SessionHandler.doHandle( 7)

at org.eclipse.jetty.server.handler.ContextHandler.doHandle( 1)

at org.eclipse.jetty.servlet.ServletHandler.doScope(

at org.eclipse.jetty.server.session.SessionHandler.doScope( )

at org.eclipse.jetty.server.handler.ContextHandler.doScope( )

at org.eclipse.jetty.server.handler.ScopedHandler.handle(

at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandler

at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.jav a:149)

at org.eclipse.jetty.server.handler.HandlerWrapper.handle( at org.eclipse.jetty.server.Server.handle(

at org.eclipse.jetty.server.HttpConnection.handleRequest(

at org.eclipse.jetty.server.HttpConnection$RequestHandler.headerComplete(HttpConne

at org.eclipse.jetty.http.HttpParser.parseNext( at org.eclipse.jetty.http.HttpParser.parseAvailable(

at org.eclipse.jetty.server.AsyncHttpConnection.handle( )

at a:586)

at$ :44)

at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob( )

at org.eclipse.jetty.util.thread.QueuedThreadPool$

at Source)

I should mention that LDAP auth seems to be working fine in Spark itself, just can’t login to web admin page. Also, dunno if it’s relevant but, I had to do the following to get 3.9.2 working with LDAP:

  1. Stop Openfire
  2. Edit conf/security.xml and remove the ldap.* entries in the encrypted properties list
  3. Restore the original LDAP authentication credentials into the conf/openfire.xml file
  4. Start Openfire

Did not do step 3 (left ldap credentials encrypted even though ldap.* entries were removed from security.xml)

So I just uninstalled 3.9.3 because users were reporting issues seeing people in other groups, and since I couldn’t log in to administer I just uninstalled and reverted back to 3.9.1. Copied over backup of Program Files (x86)\Openfire from when we were running 3.9.1 and now the Spark issues are gone but I still can’t log into web admin. Same error.

This error appears to be related to the recent change in the IgniteRealtime community pages. The team has recently switched over to using SSL, and the RSS feed links embedded within the Openfire admin console are referring to outdated (non-SSL) locations.

Created OF-798 to track this issue.

1 Like

Based on what Tom said, I was able to work around the problem by putting this entry in the “hosts” file on my Openfire server:

We can log in to the admin console now.

Thanks Tom

I am getting this exact error with a more or less fresh install of 3.9.3 that was having no problems with the admin console prior.

This hosts file mentioned, where might that be? I am unable to find it anywhere within the openfire directory?

He meant this C:\Windows\System32\drivers\etc\hosts file. After you add this line into hosts and able to login. Create a System Property in Openfire Admin Console:


with a value false

I have done this the first day RSS links were added into Admin Console and honestly, i think Admin Console is not the place for this abomination. And now it cause people problems with logins? This is mad. Remove them and gone with the problems…

Thanks Tom,

This guided me to disable RSS on admin dashboard. For this, simply navigate to ‘http://server:9090/server-properties.jsp

Then add key-value pair=> rss.enabled / false

That is it!

This fixed the problem for me.