Java Issue


i just got my new VPS and tried to install Java and wildfire. My OS is debian sarge.

I downloaded Java JRE 1.5.08 and extracted it to /usr/local/java, java folder has 755 rights and java direct link is /usr/local/java/bin/java .

then i installed Wildfire 301, created a jabber user and wanted to start: su jabber -c “/usr/local/wildfire/bin/wildfire start”

Result: No suitable Java Virtual Machine could be found on your system.

The version of the JVM must be at least 1.5.

Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.

You can also try to delete the JVM cache file /home/jabber/.install4j

Limiting Java Cache had no success, too, and commenting exit 83 too, everything no effect.


so you may want to use not the default wildfire script.

Try it with

JAVA_OPTIONS=''-Xms24m -Xmx24m -Xss128k -Xoss128k''
# JAVA_OPTIONS="${JAVA_OPTIONS} -XX:+PrintGCDetails -Xloggc:${WILDFIRE_HOME}/logs/gc.log" cd ${WILDFIRE_HOME}/bin
nohup ${JAVA_HOME}/bin/java -server -jar ../lib/startup.jar >${WILDFIRE_HOME}/logs/nohup.out 2>&1 &

You may want to uncomment the IPv4 line if you are not using IPv6.

You may want to uncomment the GC line if you want to have some basic memory profiling.

I run wildfire with these options, but with Xmx slightly higher.


PS: As described in the tag has a problem with &, the last script line should read:

nohup $/bin/java -server -jar …/lib/startup.jar >$/logs/nohup.out 2>&1 &