powered by Jive Software

java.lang.OutOfMemoryError

Hello,

I have Wildfire 2.5.4 and jre1.5.0 Update 06 On a Windows Server 2003

This Morning, i had the problem of java.lang.OutOfMemoryError: Java heap space Exception .

Seems to be Xms64m -Xmx128m problems.

My Memory usage begin with 64 Mb of maximum memory, the connections with the Pandion client could not be made. After a while, i enter and the memory usage was in 82,01 MB of 493,06 MB and all is working ok.

I’‘ve read a lot of threads about this problem but i don’'t find WHERE to change the parameters in a Wildfire Default installation. I ve to create a script? Thanks!

Hi Damien,

read Wifi Installation Guide[/url] and look for wildfired.exe.vmoptions or wildfire-service.exe.vmoptions. Don’'t create wildfired.exe.vmoptions.txt files. I recommend to set Xms to 1/4 to 1/2 of Xmx, so maybe to[code]-Xms64m

-Xmx256m[/code]

If you have the time to read http://www.tagtraum.com/gcviewer.html - so you may log the memory usage and tune the Xms value.

LG

Hello and thanks fot the answer. I have create the service and i start it with command line

wildfire-service /start

Everything works fine but the log still in a max value of 64 in my wildfire console. The file is wildfire-service.exe.vmoptions (no extension) and the value are:

-Xms128m

-Xmx256m

-verbose:gc

Any idea?

Hi Damien,

does it work if you use the launcher wildfire.exe to start it together with a wildfire.exe.vmoptions file? It must be in the bin directory where you find wildfire.exe.

There’‘s no reason not to work, I didn’‘t test it with 2.5.1 yet on Windows, but as 2.4.0 accepts the .vmoptions files I hope that’'s still the case for 2.5.1

LG

Hello . I can’'t resolve my problem with the wildfire-service.exe.vmoptions. If i edit it i have:

-Xms128m

-Xmx256m

-verbose:gc

In the Wildfire console i have:

Memoria de Java

42,04 MB of 63,56 MB (66,1%) used.

I start the service with command line in :

C:\Archivos de programa\wildfire\bin>wildfire-service /start

I can’'t understand what i am doing bad. Thanks for an answer!

Try settings this via the environment variable JAVA_OPTS="-Xmx…"

Hi,

is your vmoptions file located here:

C:\Archivos de programa\wildfire\bin\wildfire-service.exe.vmoptions ?

I did create it with notepad, with

C:\Archivos de programa\wildfire\bin>notepad wildfire-service.exe.vmoptions

and it reflects the changes I do to it. I assume you did restart Wifi after changing the file, as it is read before the java process is started.

LG