powered by Jive Software

Java memory

Hello, My name is Elias, and i have a one question, how I make to increase the memory of mine I java that this in 80%? he has some problem if to blow up? Thanks!

Welcome Elias,

it would help if you’'d tell us your operating system, and if you did read the Wifi installation guide[/url] and where you did get stuck.

LG

Advanced users may wish to pass in parameters to the Java virtual machine (VM) to customize the runtime environment of Wildfire. You can do this by creating vmoptions files in the bin/ directory of your Wildfire installation. For the Windows service, you’‘d create a new text file called wildfire-service.vmoptions. Each parameter to the VM should be on a new line of the file. For example, to set the minimum heap size to 512 MB and max VM heap size to 1024 MB, you’'d use:

-Xms512m

-Xmx1024m

To create parameters for the normal launcher, create a file called wildfired.vmoptions (since the wildfire.exe launcher invokes the wildfired.exe executable to actually start the server).[/i]

Hi,

I try these steps, restarted the machine but the Java memory remains exactly like before…

Can you help my? What I´ll doing wrong?

Thanx a lot for your support!!

Hi Elias,

what operating system are you using and what did you do?

A common windows error is that one creates the vmoptions file with a .txt extension.

LG

We are using Windows2003 Server running MySQL Database 1.4 associated with Wildfire.

The file is .vmoptions extension, I remove de .txt extension while creating the file for the first time.

The file wildfired.vmoptions need to have the XM parameters too? Ours Windows loads the wildfire in the startup menu, not like a service (runs wildfire.exe in the windows startup menu…) so what of these 2 files we need to setup? wildfire-service.vmoptions ou wildfired.vmoptions? Or both?

One more thing: the parameters -xms512m… and -xmx1024m… will needed to have the “-” atribute inside the file *.vmoptions?

Thanks!!

Hi,

as you are using the Startup folder and there probably a link to wildfire.exe you need the wildfired.vmoptions file as described. It does not hurt to have both files, the other one will be ignored.

May I ask for the reason why you’'re using the Startup folder and not the service option?

Every line should have only one JVM parameter, with the leading “-”. They will be added as-is somewhere to the java call. So you must include it or your JVM may complain during startup.

LG