powered by Jive Software

Jdbc option sql_select_limit=default

Hello,

Openfire returned the following with external users enabled:

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘OPTION SQL_SELECT_LIMIT=DEFAULT’ at line 1

Fix is to upgrade the mysql JDBC, which I did on latest removing the error. Seems to be present in 5.1.18-5.1.21ish or thereabouts…

Openfire 3.8.2

More here:

http://bugs.mysql.com/bug.php?id=66659

http://www.docjar.com/html/api/com/mysql/jdbc/StatementImpl.java.html