Jingle audio demo - doesn't work?

Hi all,

I have been trying to get the Jingle demo from SVN to work, but whenever I run it I get bind exceptions:

java.net.BindException: Cannot assign requested address: Cannot bind

at java.net.PlainDatagramSocketImpl.bind0(Native Method)

at java.net.PlainDatagramSocketImpl.bind(Unknown Source)

at java.net.DatagramSocket.bind(Unknown Source)

at java.net.DatagramSocket.(Unknown Source)

at java.net.DatagramSocket.(Unknown Source)

at de.javawi.jstun.test.demo.ice.Candidate.(Candidate.java:36)

at de.javawi.jstun.test.demo.ice.ICENegociator.gatherCandidateAddresses(ICENegocia tor.java:83)

at org.jivesoftware.smackx.jingle.nat.ICEResolver.initialize(ICEResolver.java:81)

at org.jivesoftware.smackx.jingle.nat.TransportResolver.initializeAndWait(Transpor tResolver.java:387)

at org.jivesoftware.smackx.jingle.nat.ICETransportManager.(ICETransportManag er.java:36)

There’s a few posts about this from a couple of years ago but there doesn’t seem to be a solution. Has anyone successfully used Jingle in smack?

I have already tried stuff such as changing the default STUN server to no avail.


I have similar problem. I’m trying to make audio session between two smack clients. Clients are in dwo different local networks. First in Full cone NAT and second in Port Restricted NAT.

On my side (full cone NAT) creation of ICETransportManager is successfull, but on the other side - bindexception - like Adrew’s. (I’m using winXP, other side - win7, firewalls disabled)

I have tried a lot of different STUN servers, but the result is always the same. I have even tried it with Smack 3.2.0 beta, but with the same result.

Like Andrew, i have seen a lot of old posts with this problem, but there is no clear answer how to make it work. Maybe bug is on the library side (jstun)?

Have anyone solved it?

Please, help!




I have checked win7 on my side - there was bindexception. Maybe there are some security aspects in win7?


Ok, I have found, that this error is created by:

this.socket = new DatagramSocket(0, address.getInetAddress());

in Candidate.java which is created in ICEResolver.java - jstun library. So it seems to have a bug.

Is there any solution for that?