powered by Jive Software

JingleNodes & Openfire 3.8.2 & Jitsi videobridge

Hi Everyone,

after struggling a lot with the plugin for statistics and archiving now i’m trying to use the setup in subject.

I did download the jitsivideobridge (not the plugin) and jointly with the jitsi communicator I’m able to do conference and audio-video calls.

What I wanted to do was to set up jingle nodes to be able to let the client communicates each other even if the direct connection for the p2p is not possibile.

What i did was to download the jinglenodes plugin. The strange thing is even if the system seems to identificate the pubblic ip it is not able to verify it (so it displays the correct if on the override section but no verification is possible).

Once more, when we replicate the jinglenodes config on jitsi it start the communication correctly the user answer but we do have no audio /video in any way we try.

The setup on jitsi was really simple, we enabled only jingle nodes disabling anything else like STUN but the result is what described above.

Does anyone have an idea on what could be wrong in the described setup?

Regards

we tried also to use a pure nat with no firewall set up but even doing this the result does not change and the message obtained on the jingle nodes setup page is:

  • Jingle Nodes Requires a Public IP for Internet Calling. Public IP Found:* none

**
**and on the cell tagged as “Override Public IP” the correct public ip is displayed.

The answer is to modify the code in jingleNodes as given in this thread:

The hardcoded value of ‘stun.xnet.com’ is the culprit.