powered by Jive Software

Jive Messenger setup tool fails to connect to the MySql database

Does anyone know what will resolve the Jive Messenger IM server error message “A connection to the database could not be made. View the error log …” comes back from the setup tool at http://127.0.0.1:9090.

“GetConnection was called before the internal pool was initialized.”

“ConnectionManager failed to obtain a connection.”

Can anyone help?

I am running Redhat Linux 9.0 with all Jive Software IM Server 2.0.x and MySql version 3.23.58.

File missing according to the setup instructions: jive_xmpp_mysql.sql. After unzipping the files, jive_xmpp_mysql.sql could not be found. Where can I get this file from?

Setup Instructions

  1. Make sure that you are using MySQL 3.23.2 or later and the MyISAM table type (default).

  2. Create a database for the Jive tables:

mysqladmin create

(note: “databaseName” can be something like ‘‘jivexmpp’’)

  1. Import the schema file from the database directory of the installation folder:

Unix/Linux: cat jive_xmpp_mysql.sql | mysql ;

Windows: type jive_xmpp_mysql.sql | mysql ;

  1. Start the Jive Messenger setup tool, and use the appropriate JDBC connection settings.

The file can be found in the database directory of the distribution. To connect to MySQL – make sure you’'ve granted permission for localhost to connect to the database (in MySQL docs).

Regards,

Matt

I am having the same problem. The file mentioned in the last post did not come with my distro. Here is the directory;

ls -1

messenger_db2.sql

messenger_mysql.sql

messenger_postgresql.sql

messenger_hsqldb.sql

messenger_oracle.sql

messenger_sqlserver_2000.sql

I used messenger_mysql.sql instead. Still does not connect.

Sorry about that – looks like the docs need to be updated to use the new SQL script names. If you’‘re having trouble connecting to MySQL – that’'s likely a permissions problem. After first installing MySQL you need to grant permission for local connections. See:

http://dev.mysql.com/doc/mysql/en/GRANT.html

Thanks,

Matt

Tried this with no luck;

mysql> GRANT ALL ON jivexmpp.* TO ‘’’’@’‘localhost’’;

Still getting this in error.log;

2004.12.20 15:38:50 org.jivesoftware.database.DefaultConnectionProvider.getConnection(DefaultConnect ionProvider.java:68) Warning: DbConnectionDefaultPool.getConnection() was called before the internal pool has been initialized.

2004.12.20 15:38:50 org.jivesoftware.database.DbConnectionManager.getConnection(DbConnectionManager. java:95) WARNING: ConnectionManager.getConnection() failed to obtain a connection.

make sure you can telnet localhost 3306 and have it connect, I had that problem, where my host had put a line in my my.cnf that made mysql not listen on ports.

Randy

Got it!

It wanted user localhost.localdomain to be granted privilleges to the mysql database. Not just localhost.