powered by Jive Software

JSJAC Librarie

Hi everyone,

I am trying now for a while, to use the JsJac library with openfire but without any success.

I am using the latest version of openfire and the JsJac 6.1 version.

I just want to connect to the example page “simpleclient.html”, I have tried lots of solutions i’'ve found on the web but without success.

So after serious nervous times passing on forums, I would like to know if someone have a real working doc with a real serious configuration that is sure to make just the JsJac librarie working (don’'t give solution with JwChat ou Muckl).

Thanks a lot

Cheachwood (the headache forum man)

Message was edited by: Cheachwood

Thanks to Daniel helping me to resolved

Hy there,

would be great, if i could get that support, too, so I’'d appreciate any message by Cheachwood, Daniel or anyone who already has experience concerning the matter.

Thank you

Bernd

Hi,

Here is my solution on my machine, it could be different on yours.

What you should do in the httpd.conf:

Add a virtual host, where htdocs/jsjac is the application you want to use with jsjac:

NameVirtualHost callot

Don’'t forget to activate the http-bind option on your openfire server on the port you want to, the choice of the port number is up to you. For my machine I choose the 8088 port.

Here you are.

Message was edited by: Cheachwood

Hey,

thanks so far for replying, although I’'ve found that solution in another thread, I tried to adapt it to my infrastructure without any success. I suggest, I make basical mistakes.

Environment:

  1. Working machine with APACHE (and jsjac) on Win32 platform

  2. Remote Machine in LAN running current openfire

Alternative Environment:

I’'ve also tried to run both servers on my machine just for creating your environment and checking the setup. No success.

I’'ve tried using names and IPs for connecting to the server. Would both methods work technically?

Add a virtual host, where htdocs/jsjac is the application you want to use with jsjac:

–> seems, we use the same client (script: simpleclient.html)

NameVirtualHost callot --> changed to name of my working machine with APACHE

I’‘ve installed current openfire without making any changes. The admin interface tells me, that http-bind is listening on it’‘s standard port and is enabled, so as I mentioned, I didn’'t change anything.

So in fronted GUI I’'ve entered for …

base: /http-bind/ and

server: first the remote machine’‘s IP (randomly with http://IP and even with port number), second (alternative) local machine’‘s name, third ‘‘localhost’’. I don’'t know, what else I could test now.

The Client - Debugger delivered together with the simpleclient - example tells me on Debug Level 4: “State 403 Access Denied”. The detailed message is like: “Access to directory not possible”.

So that message raises my suspicion, that there is a basic problem with access rights or proxy settings or whatever. The running apache on my working machine has no special configuration. It’‘s just a standard installation. I set 2 Alias for accessing content outside htdocs folder and of cause I implemented your setup … that’'s all so far.

So I’'m running out of ideas. How about you?

Regards