powered by Jive Software

Keystore not accepting password

I am trying to change the keystore password, but each time I enter the default password - changeit - it throws the following error:

keytool error: gnu.javax.crypto.keyring.MalformedKeyringException: incorrect magic

Has anyone come across this error before?

Thanks,

Shawn

I get the same results. Brand new installation from 3.4.5-1.i386.rpm on new RHEL5 server.

What gives?

The one thing I did change was the name of the openfire server to something other than the system hostname. I need to create new certs, but since the default password doesn’t seem to work…

I did finally got this to work. It seems that there is some conflict between the versions of keytool that exists on the server. Therefore, the way that I solved this was to invoke the explicit path, to my jdk, using it’s keytool app.

For example -

/usr/local/jdk1.5.0_04/bin/keytool <- the jdk I am using on the server

Example of command -->

/usr/local/jdk/keytool -certreq -keystore keystore -alias example.com -file certificate_file

and that worked.

Let me know if this helps.

that was the trick. thanks sayers!