powered by Jive Software

LDAP (AD) Help

Please help…

I have been now trying for over a week to get Jive to connect to our Win2K domain with very little success. I’'ve searched the forums high and low to try to find the answer and as yet have still not found it. Below is my config and also the debug log:

<?xml version="1.0" encoding="UTF-8"?>

9090

9091

Administrator

en

192.255.100.150

389

sAMAccountName

cn

mail

CN=Users,DC=STONEHARDY

CN=Administrator,CN=Users,DC=STONEHARDY

#######

true

org.jivesoftware.messenger.ldap.LdapUserProvider

org.jivesoftware.messenger.ldap.LdapAuthProvider

org.jivesoftware.database.EmbeddedConnectionProvider

true

true

2005.04.15 09:20:07 Created new LdapManager() instance, fields:

2005.04.15 09:20:07 host: 192.255.100.150

2005.04.15 09:20:07 port: 389

2005.04.15 09:20:07 usernamefield: sAMAccountName

2005.04.15 09:20:07 baseDN: CN=Users,DC=STONEHARDY

2005.04.15 09:20:07 alternateBaseDN: null

2005.04.15 09:20:07 nameField: cn

2005.04.15 09:20:07 emailField: mail

2005.04.15 09:20:07 adminDN: CN=Administrator,CN=Users,DC=STONEHARDY

2005.04.15 09:20:07 adminPassword: ########

2005.04.15 09:20:07 searchFilter: (sAMAccountName=)

2005.04.15 09:20:07 ldapDebugEnabled: true

2005.04.15 09:20:07 sslEnabled: false

2005.04.15 09:20:07 initialContextFactory: com.sun.jndi.ldap.LdapCtxFactory

2005.04.15 09:20:07 connectionPoolEnabled: true

2005.04.15 09:20:07 autoFollowReferrals: false

2005.04.15 09:20:08 Loading plugin admin

2005.04.15 09:21:00 Trying to find a user’'s DN based on their username. sAMAccountName: Administrator, Base DN: CN=Users,DC=STONEHARDY…

2005.04.15 09:21:00 Creating a DirContext in LdapManager.getContext()…

2005.04.15 09:21:00 Created hashtable with context values, attempting to create context…

2005.04.15 09:21:00 … context created successfully, returning.

2005.04.15 09:21:00 Starting LDAP search…

Note: we have only a single label domain name

My problem is that it never gets past this, and when logging into the admin console the browser just sits and waits for a response back. This is a very similiar problem to the following thread (http://www.jivesoftware.org/forums/thread.jspa?messageID=96348��) but I am using an IP address for the host.

More over I have checked that I am able to connect to LDAP with Softerra LDAP Browser and it all works. I have also checked on the server running Jive and the domain controller that a network connection has been established between them with NETSTAT and it has.

I’‘ve also tried my own user account (which is a member of Administrators, Domain Admins and Enterprise Admins) and got no further. And also created new user accounts with full admin rights on the domain to check that it’'s not a problem with the user credentials.

It is also worth noting that I have tried to configure Jive on both a Windows 2003 server and my own development machine (Windows XP) and both encounter this same problem.

The symptom appears to be that the search never returns from Active Directory and so the browser never gets sent a response to the login request. However, I do not know why this is happening.

Any help on this would be gratefuly recieved!

Thanks

Mark

Mark,

You don’‘t have a way to debug what searches are being run in AD do you? We don’‘t have AD setup locally so I’‘m at a bit of a loss as to what’‘s going on. We do all our testing with OpenLDAP and haven’'t run into this type of issue before.

Thanks,

Matt

Thanks for the quick response. I will look into trying to trace/debug what is going on within the AD search, although I am not to optimistic about what I will be able to get at it being Microsofts own technology.

I will also look at creating a completely new and seperate domain within a test environment with both with a single labelled and more conventional multi labelled domain name to see if this has any bearing on the results returned.

Mark