powered by Jive Software

Linux FC5 + Tomcat 5.5 + Java 1.5.0_06 unable to get contact list

Hi,

I’'m trying to run WildFire server on the above mentioned configuration. I can log in to the server and the server shows my user as ONLINE. The same thing works for the second user. BUT I cannot send msgs between the two users nor can I add them into the list of contacts.

I have tried connecting from another machine as well. No go. No firewall running on my box.

Here is what I see in the log.

java.lang.Exception: Failed to create connection to remote server

at org.jivesoftware.wildfire.server.OutgoingSessionPromise.createSessionAndSendPac ket(OutgoingSessionPromise.java:139)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise.access$300(OutgoingSess ionPromise.java:37)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise$1$1.run(OutgoingSession Promise.java:91)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java: 650)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)

at java.lang.Thread.run(Thread.java:595)

2006.05.19 09:58:04 Connect Socket[addr=/192.168.102.109,port=1322,localport=5222]

2006.05.19 09:59:24 Error sending packet to remote server

Thanks in advance for all your help.

thanks,

bemtya.

Hi bemtya,

you could disable s2s to make sure that “Failed to create connection to remote server” will no longer be displayed (page /server2server-settings.jsp). But this will be usually just a dirty workaround.

Did you set up a server name for your server like jabber.org? Or are you trying to use “192.168.102.109” as the server name? You could change the server name on page /server-props.jsp and make sure that you have a DNS record which matches your server name. Both clients should use the server name when connecting to the server.

LG

A common mistake when adding users to the contact list is to NOT use the server name but something else like an IP address. So if you server name is myexample.com[/i] then make sure that you add users of the form john@myexample.com[/i] and not john@something.com[/i]. Otherwise the server will assume that something.com refers to a remote server and will try to establish a server-to-server connection.

Regards,

– Gato