powered by Jive Software

Linux install woes

I’‘m trying to install jive messenger on fedora core 2 using the InstallAnywhere .bin installer. At first everything looked fine. I ran bin/Jive_Messenger, got the dialog and clicked start. It hummed for a minute and then the admin button became enabled. I clicked on it and nothing happened. I don’'t get any errors or log messages (that I can find).

I rebooted to windows and tried the install there. No problems. Clicking the admin button takes me to the localhost:9090 page and everything works fine. I didn’'t get that result on linux. I even tried going directly to localhost:9090 in mozilla and got a “connection refused” error.

My suspicion is that the embedded web server (which looks like jetty) is failing to start. Why is this? How can I verify this? How can I fix it?

thanks

doug

Hi Doug,

Seems that the embedded Jetty engine is not being started. I’'ll look into getting this fix in asap. For now, you can go to the messenger_install/bin directory and type “java -jar messengrd” to start up the application.

Cheers,

Derek

is this something everyone w/ the linux install is having trouble with or am I doing something stupid?

I ran java -jar messengerd and that is starting the webserver. I can go to the config page and run through the setup checklist. then it tells me to stop and restart the server. the only way I can figure to do that is ctrl-c. so I do. when I restart java -jar messengerd I’'m back at the checklist.

I’'ve tried using the linux messengerd.sh script instead. That seems to offer me the start/stop functionality I need. However, I get the following when attempting to use that based on the instructions at http://www.jivesoftware.org/builds/documentation/install-guide.html#config

$ ./messengerd.sh

: bad interpreter: No such file or directory

when I check that it’‘s executable using ls -l, I see that it is. I’'ve also tried this:

$ sh messengerd.sh

: command not found 2:

: command not found 11:

: command not found 14:

: command not found 18:

: command not found 22:

: command not found 26:

: command not found 29:

: command not found 32:

''essengerd.sh: line 34: syntax error near unexpected token `in

''essengerd.sh: line 34: `case $0 in

Is there a bug in this script? I notice that this script has a comment mentioning solaris and is identical to the one for solaris and macosx.

thanks for your help.

doug

Message was edited by: daxis

this is a bug, edit messengerd.sh, in line 1 change

#! /bin/sh

to

#!/bin/sh

delete the space.

changing “#! /bin/sh” to "#!/bin/sh didn’'t seem to change anything.

we were able to get the server running and everything seems to be normal if we just run XMPPServerStarter from the command line. we’'re ok for now, but it would be nice if the script worked.

thanks

doug

The shell script is in DOS format, which often hoses up shell scripts. You might try converting it to UNIX. If you open it with vi/vim the commands are

:set ff=unix
:w

Ah, now THAT made a difference. the shell script runs now, thanks.

Interestingly, the start command prints a message saying “Starting Jive Messenger…” but never shows the started message and the web server remains unloaded. However, if I run messengerd.sh console, everything seems to start as normal and I can access the control panel via the webserver. Thoughts?

thanks

doug

another method of changing the line endings is:

tr “\r” “\n” < messengerd.sh > messengerd.sh.new

Good Day

Josh Meekhof