powered by Jive Software

Lista de usuários não aparece (openfire + openldap)

Olá Pessoal,

Não estou conseguindo compartilhar os meus usuários, tenho uma autenticação com o openLdap vejo todos os grupos, mas não consigo compartilhar os usuários.

Segue o print da minha tela de confuiguração.

Alguém sabe como resolver?

Olá amigo, quando você seleciona o grupo, ele não aparece a seguinte tela:

openfire.png

Nesta tela você ativa o compartilhamento do grupo com os demais usuarios ou grupos.

Sim aparece …

todos os meus usuários fazem parte de um grupo que chamei de “im” que é compartilhado mas não aparece os membros na tela de baixo e quando listo os grupos (conforme o print) eles aparecem zerados.

Não sei se preciso fazer alguma configuração extra no openfire, li muitos artigos e posts falando do AD, mas não achei algum falando da integração com o openLdap.

Olá Pessoal,

Alguém já passou por esse problema?

Amigo, tem como postar uma foto de como aparece no console do openfire, e de como parece no cliente do spark?

Olá Vinicius,

Segue os prints das telas:

Todos estão cadastrados no ldap no grupo “im”

Obrigado pela ajuda de todos,

Feliz Ano Novo para todos …





Olá amigo, e você consegue clicar duas vezes dentro do grupo para ver as opções, exemplo:

open-exemplo.png

Nessa segunda parte que ele mostra em branco?

Também tem que ver as permissões do grupo, parece que o openfire não consegue ler o grupo.

Olá Vinicius,

Essa parte dos membros do grupo eu não consigo ver o restante consigo ver normalmente, como faço para dar permissão para os grupos no openfire?

Mão aparece aquela parte para adicionar membros no grupo acredito que seja porque ele herda do openLdap.

Amigo, clicando duas vez em cima do grupo ele não abre essa segunda tela?

Permissão que eu digo no seu LDAP, derrepente precisa adicionar nas permissões do grupo, o usuário que você utilizou para fazer a conexão.

Olá Vinicius ele não aparece nem clicando 2x .

Estou utilizando como usuário administrador do openfire o redes03 que é o meu usuário mesmo.

No openLdap o usuário admin que é o administrador.

Fiz um teste agora de logar como admin e não funcionou, ficou a mesma coisa, já reiniciei o servidor do openfire e continua igual, mais alguma sugestão?

OBS. O que achei estrnaho é que não aparece nenhum grupo e membro fica tudo zerado.


Juno, aquele grupo IM, nas permissões ou segurança dele, ambos os usuarios tem controle total?

Eu tiveu m problema parecido no AD, que alguns usuários não eram membros de nenhum grupo, dai eles não estavam aparecendo, pois o openfire só lê os grupos, e dai os usuarios membros daquele grupo que aparecem para compartilhar os contatos, e que tem permissão para conectar no openfire.

Você consegue conectar no spark com algum usuario alem dos administradores?

sim consigo conectar com qualquer usuário, mas não consigo enxergar nenhum outro usuário e quando envio mensagem para um usuário que conheço não chega, mas quando envio a mensagem pela interface os usuários conectados recebem.

Amigo, desculpe, estou sem ideias, como eu não trabalho com Linux/LDAP, não tenho conhecimento, você tem algum firewall neste servidor openfire?

Não nenhum firewall, estou continuando a pesquisa, se descobrir o erro posto aqui…

Obrigado pela ajuda.

Olá Pessoal,

Consegui resolver o problema, no caso temos que deixar os grupos do ldap em modo posix em false e em membersGroup colocamos memberUid.

O restante fica igual.

Valeu pessoal pela ajuda !