powered by Jive Software

Locked out admin console?

Hi, I was wondering if someone could help me on why i cant seem to reset the admin pass, as for some reason it locked me out saying

Login failed: make sure your username and password are correct and that you’re an admin or moderator.

As it seems i got locked out i went to the openfire.xml and changed true to false restarted the openfire and went though the setup progress and put in the new password but no luck? I saw to add username but i dont think this version handles it. Then i tried on another VM with a new database did the same procedure and it worked. So then i thought it was the VM copied the DB that does not want to change the password to the VM that did work and again no luck.

any more ideas ?

Running Openfire, Version: 3.10.2 On windows using java

Thank you

You can try adding some user as admin Resetting admin passwords (just remove spaces in tags)

Thanks for the reply

But no luck this the code i added username sistemas

<?xml version="1.0" encoding="UTF-8"?>

<!--
    This file stores bootstrap properties needed by Openfire.
    Property names must be in the format: "prop.name.is.blah=value"
    That will be stored as:
        <prop>
            <name>
                <is>
                    <blah>value</blah>
                </is>
            </name>
        </prop>

    Most properties are stored in the Openfire database. A
    property viewer and editor is included in the admin console.
-->
<!-- root element, all properties must be under this element -->
<jive> 
  <adminConsole> 
    <!-- Disable either port by setting the value to -1 -->  
    <admin> 
      <authorizedUsernames/>  
      <authorizedJIDs>sistemas@zeus</authorizedJIDs> 
    </admin>  
    <port>9090</port>  
    <securePort>9091</securePort> 
  </adminConsole>  
  <locale>en</locale>  
  <!-- Network settings. By default, Openfire will bind to all network interfaces.
      Alternatively, you can specify a specific network interfaces that the server
      will listen on. For example, 127.0.0.1. This setting is generally only useful
       on multi-homed servers. -->  
  <!--
    <network>
        <interface></interface>
    </network>
    -->  
  <!-- SPDY  Protocol is npn. 
    	(note: npn does not work with Java 8) 
    	add -Xbootclasspath/p:/OPENFIRE_HOME/lib/npn-boot.jar to .vmoptions file    -->  
  <!--     
    <spdy> 
    	<protocol>npn</protocol> 
    </spdy> 
    -->  
  <connectionProvider> 
    <className>org.jivesoftware.database.EmbeddedConnectionProvider</className> 
  </connectionProvider>  
  <setup>true</setup> 
</jive>

Thank you

So you can’t login to Admin Console with user sistemas? You can add it to usernames instead simply as sistemas (without @zeus). Also, you should do this while Openfire is stopped and when you run Openfire again this code should disappear from the file as Openfire imports it to the database. If that doesn’t work, can’t help. Maybe database was corrupted.

Thanks for the reply, i stoped the server added the line sistemas then started and tried the password no luck. When you mean about add it to the username instead of simply as without @zeus would you mean this

<?xml version="1.0" encoding="UTF-8"?>

<!--
    This file stores bootstrap properties needed by Openfire.
    Property names must be in the format: "prop.name.is.blah=value"
    That will be stored as:
        <prop>
            <name>
                <is>
                    <blah>value</blah>
                </is>
            </name>
        </prop>

    Most properties are stored in the Openfire database. A
    property viewer and editor is included in the admin console.
-->
<!-- root element, all properties must be under this element -->
<jive> 
  <adminConsole> 
    <!-- Disable either port by setting the value to -1 -->  
    <admin> 
      <authorizedUsernames/>  
      <authorizedJIDs>sistemas</authorizedJIDs> 
    </admin>  
    <port>9090</port>  
    <securePort>9091</securePort> 
  </adminConsole>  
  <locale>en</locale>  
  <!-- Network settings. By default, Openfire will bind to all network interfaces.
      Alternatively, you can specify a specific network interfaces that the server
      will listen on. For example, 127.0.0.1. This setting is generally only useful
       on multi-homed servers. -->  
  <!--
    <network>
        <interface></interface>
    </network>
    -->  
  <!-- SPDY  Protocol is npn. 
    	(note: npn does not work with Java 8) 
    	add -Xbootclasspath/p:/OPENFIRE_HOME/lib/npn-boot.jar to .vmoptions file    -->  
  <!--     
    <spdy> 
    	<protocol>npn</protocol> 
    </spdy> 
    -->  
  <connectionProvider> 
    <className>org.jivesoftware.database.EmbeddedConnectionProvider</className> 
  </connectionProvider>  
  <setup>true</setup> 
</jive>

But you also mention when i start the openfire server that line should be gone during or after openfire server?

Thank you

I mean the tag which is above the one you have put sistemas in - authorizedUsernames. Just edit that tag so it looks the same as authorizedJIDs, but only put sistemas in there, without @zeus.

Thanks for the reply so something like this

<?xml version="1.0" encoding="UTF-8"?>

<!--
    This file stores bootstrap properties needed by Openfire.
    Property names must be in the format: "prop.name.is.blah=value"
    That will be stored as:
        <prop>
            <name>
                <is>
                    <blah>value</blah>
                </is>
            </name>
        </prop>

    Most properties are stored in the Openfire database. A
    property viewer and editor is included in the admin console.
-->
<!-- root element, all properties must be under this element -->
<jive> 
  <adminConsole> 
    <!-- Disable either port by setting the value to -1 -->  
    <admin> 
      <authorizedUsernames/> sistemas 
      <authorizedUsernames/>  
      <authorizedJIDs>sistemas@zeus</authorizedJIDs> 
    </admin>  
    <port>9090</port>  
    <securePort>9091</securePort> 
  </adminConsole>  
  <locale>en</locale>  
  <!-- Network settings. By default, Openfire will bind to all network interfaces.
      Alternatively, you can specify a specific network interfaces that the server
      will listen on. For example, 127.0.0.1. This setting is generally only useful
       on multi-homed servers. -->  
  <!--
    <network>
        <interface></interface>
    </network>
    -->  
  <!-- SPDY  Protocol is npn. 
    	(note: npn does not work with Java 8) 
    	add -Xbootclasspath/p:/OPENFIRE_HOME/lib/npn-boot.jar to .vmoptions file    -->  
  <!--     
    <spdy> 
    	<protocol>npn</protocol> 
    </spdy> 
    -->  
  <connectionProvider> 
    <className>org.jivesoftware.database.EmbeddedConnectionProvider</className> 
  </connectionProvider>  
  <setup>true</setup> 
</jive>

Thank you

EDIT: i think its corrupted i was able to login on spark as admin https://ibb.co/k5uwex

Now looking at this the only way to start from scratch, is there a way i can see the password of the users as i did not document it :frowning:

Thank you

No, i meant < authorized Usernames>sistemas< /authorized Usernames> without the spaces before <.

Passwords may be encrypted. But you can try opening /openfire/embedded-db/openfire.script with a text editor and look for it.

Thanks for the reply,
but still no luck the username would be sistemas with the password that is working on spark right?

<?xml version="1.0" encoding="UTF-8"?>

<!--
    This file stores bootstrap properties needed by Openfire.
    Property names must be in the format: "prop.name.is.blah=value"
    That will be stored as:
        <prop>
            <name>
                <is>
                    <blah>value</blah>
                </is>
            </name>
        </prop>

    Most properties are stored in the Openfire database. A
    property viewer and editor is included in the admin console.
-->
<!-- root element, all properties must be under this element -->
<jive> 
  <adminConsole> 
    <!-- Disable either port by setting the value to -1 -->  
    <admin> 
      <authorizedUsernames>sistemas</authorizedUsernames>  
      <authorizedJIDs>sistemas@zeus</authorizedJIDs> 
    </admin>  
    <port>9090</port>  
    <securePort>9091</securePort> 
  </adminConsole>  
  <locale>en</locale>  
  <!-- Network settings. By default, Openfire will bind to all network interfaces.
      Alternatively, you can specify a specific network interfaces that the server
      will listen on. For example, 127.0.0.1. This setting is generally only useful
       on multi-homed servers. -->  
  <!--
    <network>
        <interface></interface>
    </network>
    -->  
  <!-- SPDY  Protocol is npn. 
    	(note: npn does not work with Java 8) 
    	add -Xbootclasspath/p:/OPENFIRE_HOME/lib/npn-boot.jar to .vmoptions file    -->  
  <!--     
    <spdy> 
    	<protocol>npn</protocol> 
    </spdy> 
    -->  
  <connectionProvider> 
    <className>org.jivesoftware.database.EmbeddedConnectionProvider</className> 
  </connectionProvider>  
  <setup>true</setup> 
</jive>

Yes, password used in Spark should work for Admin Console. If it works in Spark, then something is messed up with Openfire. Can’t suggest anything else.

yep your right its screwd up the database. what im going to do is reinstall then copy the encrypted password to each user on the new database

Thanks again