Login issues since Spark 2.8.0

Your certificate is for domain chat, but you are putting chat.domain.com into Spark i suppose. So they doesn’t match. Ideally you would have your Server name as chat.domain.com and certificates for chat.domain.com (or maybe *.domain.com only would work also). But you won’t get that without changing your server, which can mess things. So, unless you want to try this and rerun the setup and set server name to chat.domain.com and then recreate certificates. Or as i’ve said on the other thread, use 2.7.7, or try the latest build with a setting to disable certificate hostname check. Latest build as of now is 900 Ignite Realtime: Spark Nightly Builds

1 Like

Or you could put chat into Spark, but on the advanced settings point it to chat.domain.com.


just wanted to add that wroot’s suggestion works perfectly as a work-around. if using the latest nightly build, selecting the new option ‘Disable certificate hostname verification (not recommended)’ on the ‘Advanced’ tab does solve the issue.

Obviously it’s not ideal for security but it does get you back into Spark.

I just installed the latest nightly build and ‘Disable certificate hostname verification’. All is good now. Hopefully they can add this to spark 8.1 .



This still does not work for me, I get “Unknown connection error.Please review the logs.”

Looking a lot like I will have to rebuild the server.


try the following settings on your spark advance section

check mark on the following:

accept all certificates

disable certificate hostname verifiaction

automatically discover host and port

Kenneth, this setting is indeed going to be in 2.8.1+ versions.

DM, do you have a thread in the forums for your issue? There is not enough information to help you and this comments thread is getting too crowdy. So i suggest posting a separate thread. Also check Spark error/warn logs and post what you find there.


Is it possibile to setup ‘Disable certificate hostname verification’ directly in the “default.properties” file in the “spark.jar” file?

Thank you.

Best regards.


No, it’s not possible.

I login spark instant message . spark give tips certification hostname verification failed.what is wrong? my spark version is 2.8.1 and Openfire is 4.0.3. following is spark screenshot

屏幕快照 2016-10-08 下午2.22.52.png

nick, you are asking “what is wrong” on a document which explains exactly what is wrong. This is just disrespectful. Read the document and do the changes you wish. Either fix your setup to not use IP to login, or enable “Disable certificate hostname verification”…

I have read this web page.I think it is not same with my question. I use IP to login beause my openfire server name is

hostname is

That’s the same issue actually. Certificates do not work normally when server’s name is IP. When you put IP into Spark’s domain field it is using it as IP, not as a name, so it still thinks that there is a mismatch in domain names.

may I change server name with localhost or any name words?

You can. By running the setup again and specifying other name during the setup (skipping the admin password step, as it is already set). Just remember to then go and remove old TLS certificates which were for domain. I haven’t tried though to name it localhost. So not sure if there won’t be same issue like using the IP address. So it is better to name it something else. Then in Spark you would put that name into Domain field and on the Advanced settings would put the IP of that server into Host field (if you don’t have any DNS setup to point to that automatically).

1 Like

Thank you all you help ! I change server name as mac name and in Spark i put that name into Domain field .login sucessful!

may I ask you another question about openfire here?

No, lets no clutter this comments section with not related questions. You can post your question in the forums.

I’m a bit confused. I put in a username of ‘aaron’ and a domain of ‘example.tld’. I have SRV records in DNS for example.tld that point to chat.example.tld. Spark finds those records and connects to chat.example.tld. But apparently spark is looking for the certificate ‘example.tld’ and not ‘chat.example.tld’. This seems wrong…