Lost upgrade document

Does anyone know where I can find the document titled “Steps for upgrading Jive Messenger to Wildfire” that is referenced both on the download page and by multiple posts under the URL http://www.jivesoftware.org/community/entry.jspa?externalID=481

Thanks,

IB

Did you ever find this document?

I’'m getting ready to upgrade from Jive 2.3.1 to the latest WIldfire and this supposed document would be very useful.

Thanks.

Max

That’'s the content (without format) - try a google search for “Steps for upgrading Jive Messenger to Wildfire” and view the cached version:

The following document identifies the steps that an admin should follow in order to upgrade an existing Jive Messenger installation to Wildfire 2.4.0.

  1. Stop Jive Messenger.

  2. Make a back of your database and current installation. Note that embedded database is stored in the embedded-db folder.

  3. Install wildfire to new location (e.g. c:
    Program Files
    Wildfire or /opt/wildfire)

  4. Copy existing conf/jive-messenger.xml from old version to conf/wildfire.xml in the new installation

  5. Replace out-of-the-box SSL certificates with previous ones by copying the files located in resources/security of the old version to the new installation

  6. Copy existing messenger-service.exe.vmoptions to wildfire-service.exe.vmoptions in the new installation

  7. If on internal db, copy the files located in embedded-db to new location renaming the items in embedded-db to have a “wildfire” prefix instead of a “jive-messenger” prefix.

  8. If using LDAP, update your wildfire.xml (was jive-messenger.xml) config and change all references from org.jivesoftware.messenger to org.jivesoftware.wildfire.

  9. If JM was installed as a service you will have to uninstall it (messenger-service /uninstall) and then install wildfire as a service (wildfire-service /install).

  10. Existing plugins must be updated to latest version. Download latest version from: http://www.jivesoftware.org/wildfire/plugins.jsp. This includes updating the SparkManager plugin that can be downloaded from http://www.jivesoftware.com/products/wildfire/sparkmanager.jsp.

  11. Start Wildfire.

Upgrading using PostgreSQL 7.x

Wildfire will automatically try to upgrade the database schema. However, the provided scripts may not always work for all database versions. Such is the case with PostgreSQL where the provided script works fine for PostgreSQL 8.x but not for PostgreSQL 7.x. If you are using PostgreSQL 7.x then you will need to replace the line:

ALTER TABLE jiveGroupUser ALTER COLUMN username TYPE VARCHAR(100) NOT NULL;

with:

ALTER TABLE jiveGroupUser RENAME TO jiveGroupUser23;

ALTER TABLE jiveGroupUser23 DROP CONSTRAINT jiveGroupUser_pk;

CREATE TABLE jiveGroupUser (

groupName VARCHAR(50) NOT NULL,

username VARCHAR(100) NOT NULL,

administrator INTEGER NOT NULL,

CONSTRAINT jiveGroupUser_pk PRIMARY KEY (groupName, username, administrator)

);

INSERT INTO jiveGroupUser (groupName, username, administrator)

SELECT groupName, username, administrator FROM jiveGroupUser23;

DROP TABLE jiveGroupUser23;

Of course, be sure to back up your database prior to running any upgrade script in the event that a restore is necessary.

Wonderful! Thanks a bunch!

Max