Make OpenFire use plainPassword for authentication


I want to use the plainPassword column for authentication of chat users,

because I’m using a webservice to fill that column with a md5 generated password.

I’ve set user.usePlainPassword to true in ofProperty, but I’m still getting:

IN: cmVhbG09ImlwcHotY2hhdCIsbm9uY2U9ImJUSm lRUzFOKzlxRDhpcGV1MCtBUzdFRE5qemhzOEdHa3ZUQ2xIY3UiLHFvcD0iYXV0aCIsY2hhcnNldD11dG YtOCxhbGdvcml0aG09bWQ1LXNlc3M=

OUT: dXNlcm5hbWU9IjJhOWFjMmYxYjA0MGFkOTRkNz IxYTdiZWZiMDQ4M2M1IixyZWFsbT0iaXBwei1jaGF0Iixub25jZT0iYlRKaVFTMU4rOXFEOGlwZXUwK0 FTN0VETmp6aHM4R0drdlRDbEhjdSIsY25vbmNlPSIxNjAwMTAxNjgzOTZhZDhmOTA0ZGRmNzA2MzczZD Q4YyIsbmM9IjAwMDAwMDAxIixxb3A9ImF1dGgiLGRpZ2VzdC11cmk9InhtcHAvaXBwei1jaGF0IixyZX Nwb25zZT0iNjRmMTY1NTBiYWM2ODRhYTY2NTI5NzZhZTdhNDg2YmIiLGNoYXJzZXQ9InV0Zi04Ig==</ response>

IN: <not-authorized/>

Anything I’m missing?

Cheers, Tom.

Hmm… maybe my question is too complicated?

Or am I asking something too obvious?


since I couldn’t change settings on the DefaultAuth and DefaultUser providers…

I added two jdbcProviders:

  • jdbcAuthProvider

  • jdbcUserProvider

they use the same tables as OpenFire would’ve in the first place…

problem solved, I guess.