Media proxy not working

I have a problem with the product.

I would like to use Media Proxy.

Firstly, I set xmpp.domain to 192.168.1.130 and I can use Media Proxy it has not any problem.

Then I change xmpp.domain to developer4 because I can’t use domain name to be IP in my production.

But I can’t use Media Proxy so I started check the problem

  • I checked destination IP and Port that I sent UDP packet and it correct both IP and Port

  • I checked in Admin Console by 127.0.0.1:9090

I checked in Media Service->Media Proxy and I saw Media session has been created.

But the value of Inactivity(secs) attribute is set to 1204602991 and continued increased

Nomatter UDP packet I sent can decrease it to 0(zero)

please tell me how can I fix it

hi.

maybe you need a dns-entry?

I also have a problem with media-proxy:

what do you mean with “I set xmpp.domain to 192.168.1.130”??

my problem is, that i have activeted media proxy in openfire, but I don’t know how to integrate it in my client? do I have to change the host-url of my client? how does my client know to use the proxy?

thx

  1. Firstly, you set enable on Media Proxy feature

  2. when your clients need to use media proxy, one client need to send xmpp request message like below

Entity Requests a candidate from Host
<iq type=‘get’ id=‘cand1’ to=‘rtpbridge.serverdomain’>
<rtpbridge xmlns=‘http://www.jivesoftware.com/protocol/rtpbridge’ sid=‘session1’>
<candidate/>
</rtpbridge >
</iq>
and your cliend will receive
Host Returns Candidates to Entity
<iq type=‘result’ id=‘cand1’>
<rtpbridge xmlns=‘http://www.jivesoftware.com/protocol/rtpbridge’ sid=‘session1’>
<candidate name=‘myvoicedata’ ip=‘200.10.11.104’ porta=‘13540’ portb=‘12555’ pass=‘pxpxpx’/>
</rtpbridge >
</iq>

  1. Now your openfire server will open 4 udp ports are (13540,13541) and (12555,12556)

when one user send udp packet to your openfire server in port 13540, another user can receive data by read from port 13541
and ports (12555,12556) working like port (13540,13541)

My xmpp.domain setting


hi tetae,

thank you very much for your help.

can you tell me whick client you use?

I did exactly what you wrote, but the clients always have a direct connection and not via media proxy.

<iq id=‘ch9159’ to=‘christophk@wildfire.domain.local/neos’ type=‘set’><query xmlns=‘neos:video’><user>christopher</user><host>192.168.1 1.164</host></query></iq><iq id=“ch9159” to=“christopher@wildfire.domain.local/neos” type=“result” from=“christophk@wildfire.domain.local/neos”><query xmlns=“neos:video”><user>christophk</user><host>192.168.11 .154</host></query></iq>

do I have to make a seperate configuration to my client to use the media proxy or should work this automatically when I enabled the media proxy in openfire?

we are using neosmt as client.

thx!!!

Good description of what media proxy actually does.

But where from OpenFire knows where to send UDP packets?

What if one of clients located behind NAT?