powered by Jive Software

Memoria do Java

Eu tenho 200 usuários no meu openfire, e a memória do java fica em 98% usado.

alterei os parâmetros do arquivo para:

-Xms1024m

-Xmx1024m

e mesmo assim nada mudou, alguém pode me ajudar?

reboot the server

Salve esse arquivo como nomeado openfired.vmoptions e coloque-o no diretório bin /.

Reinicie o servidor e ele vai funcionar

Eu tenho traduzido do google porque eu não entendo por favor tente entender correspondentemente

Bom dia, então eu salvei esse arquivo com o nome openfired.vmoptions, e coloquei no diretorio bin/.

só que mesmo com 1024MB não é o sulficiente, vejam o print, fica mostrando 98% usado

Imgur: The most awesome images on the Internet

Eu não acho que o servidor vai usar essa memória muito java para apenas 200 usuários como eu criei 1,00,000 usuário ainda está usando apenas 50% da memória eo resto da memória é gratuita e servidor é full respoding de cada ação. Qualquer processo ou thread está ativo no openfire no backgroud, a menos que isso não aconteça tanto quanto eu sei. Tente uma vez depois de reiniciar o servidor.

Então eu fiz todas essas mudanças, já reiniciei o servidor e continua igual, aí eu começo usar 1, 2 dias e ele trava, só reiniciando o servidor pra ele voltar a funcionar.

assim ele não inicia o serviço:

-Xms512m

-Xmx2048m

assim inicia o serviço, porém consome 98% da memória:

-Xms1024m

-Xmx1024m

e assim também não inicia o serviço:

-Xms1024m

-Xmx2048m

Acho que você não consegue aumentar a memória para 2048 se estiver usando o Java 32 bits.

Eu tinha esse problema de travamento e consumo alto de memória, resolvi migrando banco de dados para mysql. Hoje o consumo fica em torno de 100 MB.

Bom dia Ivan, muda para banco de dados externo, aqui eu utilizo o postgres, tenho em média 150-180 usuários online, e a memória do java fica em torno de 500mb, isso na versão 4.0.3, a versão antiga, 3.9, era a mais estável nesse quesito, eu tinha em média 150mb de memória em uso com a mesma quantidade de usuários. Ainda preciso testar a nova versão, se precisar de ajuda para instalar com banco de dados externo é só me avisar.