powered by Jive Software

Merged monitoring/open archive plugins

Thanks, fixed: http://issues.igniterealtime.org/browse/OF-664

Hi Leon,

Would you like the plugin provided by the Ignite website refreshed to the latest code? Rephrasing, would you like to make an updated release of the plugin?

daryl

Hi Daryl,

Already done

Was about to email to ask if someone could take down 1.3.0 on the Openfire Plugins page (and Dele’s post) and put the attachment here in its place:

best,

-Leon

Done.

Dele’s post updated

Leon Roy wrote:

http://issues.igniterealtime.org/browse/ OF-611 Is still pending, I know some of you who upgraded to 1.3.0 have missing messages but fear not there is no data loss. It’s still in there.

Once I have time I’ll release 1.3.2 which will safely restore those messages.

I am running OF 3.8.1 and Monitoring 1.3.1-rc1, and while I don’t have any error messages - all I get is “The messages in this conversation were not archived”. Will that be fixed in the 1.3.2 release too? Is there a workaround for now? Not being able to answer questions on past chats is awful

Thanks,

Brant

Sorry to hear. Best to create a new thread for this but in the meantime.

Few points:

  1. Are you able to see any messages in the Monitoring plugin admin pages.

Go to Server > Archiving > Click on Search

Should see something like this:

Any other screenshots would be very helpful.

  1. Gather logs immediately after reproducing the issue please. Paste the last few errors from:

C:\Program Files\Openfire\logs\error.log

C:\Program Files\Openfire\logs\warn.log

Debian Linux:

/var/log/openfire/

RedHat/CentOS:

/opt/openfire/logs/

Hi Leon,

Well, I am not sure what’s going on. My database of messages seems to be growing still, it was 6MB and now growing as we speak. It is now at 485. Here’s 2 screenshots from this morning, and the logs (via the admin panel) are all blank. I am running this on Mac OS and get a permission denied message when trying to get into the /usr/local/openfire directory.


Might be easiest if you just copy and paste the contents of your Error and Warn logs from the Openfire Admin Console page (Server > Logs).

I tried that, as I mentioned, they are all blank

I can give you remote access to this machine if you want - I’m that desperate!

Database size is now ~750 MB! Argh!

Sure, send me a private message with TeamViewer access if possible. Microsoft Remote Desktop or SSH and Web access is fine too.

(Do make sure it’s a private message otherwise you’ll have bigger issues than a leaky database

Sending PM now! Thank you so much!

Hi, did you solved empty logs? if yes, share it please. I have same issue! Thank you.

Yes, it’s resolved.

Please download the latest monitoring plugin from your Openfire > Plugins > Available Plugins page.

There is one known issue. Any logs archived by plugin 1.3.0 will not appear. I’ll release a version of the plugin at some point to resolve this.

I solved too, was a problem in log4j.xml (from ./openfire/lib i think), i edited where was " , and now seems console read the logs from corect location. The problem remains the wrong time from log. Correct day, but wrong hour.(linux time is correct)

I have already 1.3.0 rc1 for archive.Ty for reply.

Hi, Vacuum-IM supports XEP-136 http://code.google.com/p/vacuum-im/ but I get error when try to get collection list

test1@localhost/MAINPC 12:41:46 +0 >>>>

30

<<<< test1@localhost/MAINPC 12:41:46 +65 <<<<

Doesn’t work XEP-0136

Openfire 3.8.2

Monitoring Plugin 1.3.1-rc1

test1@localhost/MAINPC 12:41:46 +0 >>>>

30

<<<< test1@localhost/MAINPC 12:41:46 +65 <<<<

No sure if RSM works. I use it without RSM

Try this

This XEP could not be used without RSM, history can be too long to be send in one stanza, also RSM is used to get the latest N conversations.

test1@localhost/MAINPC 13:25:25 +7134 >>>>

<<<< test1@localhost/MAINPC 13:25:25 +23 <<<<