powered by Jive Software

Merged monitoring/open archive plugins

Hi Leon,

Well, I am not sure what’s going on. My database of messages seems to be growing still, it was 6MB and now growing as we speak. It is now at 485. Here’s 2 screenshots from this morning, and the logs (via the admin panel) are all blank. I am running this on Mac OS and get a permission denied message when trying to get into the /usr/local/openfire directory.


Might be easiest if you just copy and paste the contents of your Error and Warn logs from the Openfire Admin Console page (Server > Logs).

I tried that, as I mentioned, they are all blank

I can give you remote access to this machine if you want - I’m that desperate!

Database size is now ~750 MB! Argh!

Sure, send me a private message with TeamViewer access if possible. Microsoft Remote Desktop or SSH and Web access is fine too.

(Do make sure it’s a private message otherwise you’ll have bigger issues than a leaky database

Sending PM now! Thank you so much!

Hi, did you solved empty logs? if yes, share it please. I have same issue! Thank you.

Yes, it’s resolved.

Please download the latest monitoring plugin from your Openfire > Plugins > Available Plugins page.

There is one known issue. Any logs archived by plugin 1.3.0 will not appear. I’ll release a version of the plugin at some point to resolve this.

I solved too, was a problem in log4j.xml (from ./openfire/lib i think), i edited where was " , and now seems console read the logs from corect location. The problem remains the wrong time from log. Correct day, but wrong hour.(linux time is correct)

I have already 1.3.0 rc1 for archive.Ty for reply.

Hi, Vacuum-IM supports XEP-136 http://code.google.com/p/vacuum-im/ but I get error when try to get collection list

test1@localhost/MAINPC 12:41:46 +0 >>>>

30

<<<< test1@localhost/MAINPC 12:41:46 +65 <<<<

Doesn’t work XEP-0136

Openfire 3.8.2

Monitoring Plugin 1.3.1-rc1

test1@localhost/MAINPC 12:41:46 +0 >>>>

30

<<<< test1@localhost/MAINPC 12:41:46 +65 <<<<

No sure if RSM works. I use it without RSM

Try this

This XEP could not be used without RSM, history can be too long to be send in one stanza, also RSM is used to get the latest N conversations.

test1@localhost/MAINPC 13:25:25 +7134 >>>>

<<<< test1@localhost/MAINPC 13:25:25 +23 <<<<

Only trying to help solve your problem. There are many ways to bake a cake

I can confirm that I don’t get the error you got which confirms the problem is on your server and not Openfire or monitoring plugin. Go figure

Can you install Vacuum-IM and show what you get in XML console when try to view history?

I think you are missing the point on the error message you are getting. Openfire cannot find any IQ Handler for urn:xmpp:archive. However, I am in a good mood today, so I will humour your request

SENT

RECV

This bug!

This does not return latest message:

10

<<<< mr.lioncub@domain.loc/Work 16:20:38 +197 <<<<

<iq type=“result” id=“sid_17” to="mr.lioncub@domain.loc/

Work">







22
468
71


Latest:

<iq type="get" id="sid_17">
    <list xmlns="urn:xmpp:archive" end="2013-06-07T21:51:38.412Z" with="user1@domain.loc" start="2013-06-07T00:51:38.412Z">
      <set xmlns="http://jabber.org/protocol/rsm">
        <max xmlns="http://jabber.org/protocol/rsm">10</max>
        <before xmlns="http://jabber.org/protocol/rsm"/>
      </set>
    </list>
  </iq> <<<< mr.lioncub@domain.loc/Home 21:53:16 +136 <<<<
  <iq type="result" id="sid_17" to="mr.lioncub@domain.loc/Home">
    <list xmlns="urn:xmpp:archive">
      <chat with="user1@domain.loc" start="2013-06-07T07:05:15.407Z"/>
      <chat with="user1@domain.loc" start="2013-06-07T03:51:58.681Z"/>
      <chat with="user1@domain.loc" start="2013-06-07T12:51:44.655Z"/>
      <chat with="user1@domain.loc" start="2013-06-07T07:15:37.235Z"/>
      <chat with="user1@domain.loc" start="2013-06-07T02:19:49.308Z"/>
      <chat with="user1@domain.loc" start="2013-06-07T02:30:04.238Z"/>
      <set xmlns="http://jabber.org/protocol/rsm">
        <first index="0">15178</first>
        <last>15603</last>
        <count>6</count>
      </set>
    </list>
  </iq>

Took a look. There’s no support in the plugin for at the moment. You’ll have to use rsm and .

ie.

                <set xmlns='[http://jabber.org/protocol/rsm](http://jabber.org/protocol/rsm)'>

30

29

Actually testing the above isn’t working as I’d expect. I’ll have to dig into the XEP-0136 part of the plugin to determine the cause.

If you can, then please apply by the bug.

Server: Openfire 3.8.2. windows
Client: Vacuum-IM 1.2.3.2288

Problem with the load of history of correspondence.

Not loaded last 30 reports… If the amount of reports exceeds 30, in history of correspondence of chat they are not represented. I ask for a help.

Plagin Open archive does not work correctly, and version which worked in 3.7.1 in a version 3.8.2 does not work.