Message Carbons not working with app?

Hi I recently upgraded Openfire to 4.01 in hopes of getting XEP-0280 Message Carbons support with my app. I am running Spark also. When i am actively using Spark i get the message to my spark client but it does not get sent to my conversations app which i understand supports XEP-0280. Is there something i need to enable on the Openfire to allow this message to be sent to Conversations also? thank you.

should work with nothing special. Im running the same setup, and it seems to be working fine. if you upgraded from zip, you may need to maual enable stream management

check for the follow system properties. if they are not there, try added them true 5

1 Like

You don’t have to enable it, it works by default. I have just tried with 4.0.1, Yaxim on Android and Spark on Windows. It works.

But it is about Message Carbons, not the Stream Management.

yeah…conversations uses stream management, so I’m wondering if the client (conversations) is just going to sleep or something…

strange. I have conversations open on my device and when i receive a message to spark it doesnt show up on conversations. Is there any sort of logs that would indicate it’s even trying to send to conversations? thank you.

Does it work the other way? If you send a message from Spark, does it shows up as a sent message on conversations?

No but i assume that’s because Spark doesn’t support XEP-0280? When i open Conversations it doesnt load any history for any contacts but does show me who is online and their status.

I also tried installing Gajim on my desktop set its priority to 0 like conversations and it doesn’t get messages along with spark. Seems it’s an issue with Openfire and not conversations/gajim.

Spark doesn’t support XEP-0280, yes, so Spark won’t get a sent message in its history when it was sent from another client. But If you send a message from Spark, the other connected client, which supports that XEP, should get that sent message in its history. Works for me in Yaxim that way. I think it worked with Gajim for me also, but i don’t have it installed currently. And you don’t have to have same priorities. Usually it should be enabled by default in the client, but you can check the settings.

i had upgraded from 3.70 to 4.01 for openfire and using SQL db. Is there a chance the database isnt upgraded? is there a db setting from 3.70 that needs to be changed?

I tried a couple things tonight including removing Openfire 4.01 and installing 3.10.2 to a new directory and used my openfire.xml from the original install and still not getting carbons to work. Also tried installing 4.01 onto a completely different box and that did the same. Would there be something in the database that would prevent this from working? thank you.

You can try Yaxim (free android app). You can try installing new Openfire (with a new database) just for testing. Sorry, don’t know how to troubleshoot this.

Hello everyone,

I’m running an Openfire myself Version 3.10.2 directly on Synology 5.0. XEP-280; XEP-313 is working there! Conversations shows me under server-info XEP-0280 yes ; XEP-0313 yes.

I tried an upgrade-install of 4.0.1 in Synology directly, as well as an seperate install on Win7 as well as adding an Docker as Container in Synology 5.2. Connecting via 5222, Conversations always showed me under server-info XEP-0280 no; XEP-0313 no; not availible.

Is there some secret Menu to enable the XEP-function’s in the newer versions? Stream Management is the only one which is working out of the box, Conversations showed me under server-info XEP-0198 yes.

Thanks for that fantastic server which openfire is indeed!

As i’ve said above Cabons work fine for me with Yaxim client on 4.0.1 and now on 4.0.2. Not sure why Conversations can’t see it enabled.

Dude, you are right,

indeed it is working with Yaxim 0.8.8

But why the hell not with Conversations e.g. 1.12.8?

I can’t explain myself, esessially it is working with former versions. I will try to get in contact with Daniel Gultsch.

Thank you wroot