powered by Jive Software

Message character count limit

I’‘ve noticed that there is a 1250 character limit to messages. What I am unable to determine is if this is part of the XMPP protocol, a default setting in Jive Messenger, or a setting in the clients I’‘ve tested. I’‘ve tested this in Psi, JAJC, Exodus, Miranda, all have the same 1250 character limit. Neos gives me a slightly higher limit, about 1300 characters. When I try to send larger messages, the recipient doesn’‘t get anything, and I get disconnected from the system and must attempt to reconnect twice. If it’‘s a protocol limitation, I’‘m OK with that, but if it’‘s a modifiable setting on the server, I’'d love to be able to send larger messages. I get the same limitation when sending files - I can send a 1300 byte file, but it stalls on a 1500 byte file.

Any ideas as to the cause of this?

This is definitely not a limit imposed by the XMPP spec of Exodus… I suspect it’'s a server side limitation for Jive.

Of course, I meant the XMPP spec OR Exodus

I’‘ve filed this in the issue tracker as JM-253. We’'ll investigate and then post a follow-up.

Peter – thanks for stopping by the forums! Jive Messenger has lots of Exodus users.

-Matt

Thanks for replying so quickly!

I forgot to mention in my earlier post - I’‘m using the new version 2.1.3, so this may be a newly introduced issue. I wish I could help review the code, but my programming chops are limited to beginning python. I’'m always willing to help hunt for UI issues and do as much stress testing as I can, though.

  • JustinP

Some more info - I cleared all four logs in the admin console, and sent an oversized packet (1500 characters). The debug log spit this out when it booted my client off (IP’'s removed):

2005.04.13 12:51:24 SSL Connect 1140709[SSL_NULL_WITH_NULL_NULL: Socket[addr=/xxx.xxx.xxx.xxx,port=4490,localport=5223]]

2005.04.13 12:51:24 Logging off username@jab/Work on org.jivesoftware.messenger.net.SocketConnection@1d9e279

2005.04.13 12:51:24 Logging off jab/53e98c47 on org.jivesoftware.messenger.net.SocketConnection@1a3aa2c

2005.04.13 12:51:27 SSL Connect 1f95165[SSL_NULL_WITH_NULL_NULL: Socket[addr=/xxx.xxx.xxx.xxx,port=4491,localport=5223]]

The error log gives nothing.

The info log gives nothing.

The warn log gives nothing.

The body of the error message when it boots the user is:

"There was an error communicating with the Jabber server.

Details: Disconnected"

The first time the user tries to reconnect, they receive:

"There was an error communicating with the Jabber server.

Details: Authentication error: Unable to login"

The second attempt to login works fine.

Does this help?

Hey Justin,

In order to reproduce the problem I tried sending a message with a body containing 4000 times the X character. I’'m using the Smack library so I created two clients and the “huge” message was sent twice from one client to the other. In both cases the message was received and the connections were still alive.

Can you post here the structure of the message that you are sending? using exodus you can press F12 to get the packets being sent and received from the server. FYI, my message had this structure:

<message id="eqYLT-12" to="user1@localhost/Smack" type="chat">
  <body>X --> 4000 times</body>
</message>

Thanks,

– Gato

Here’'s a sample message with 400 characters:

SENT: 58e325fbda0f540ef781829aedebdad150480fd0Lore m ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat. Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat, vel illum dolore eu feugiat nulla faci

Side note: I’'m guessing the ‘‘thread’’ bit is due to SSL?

Here’'s one with 4000 characters:

SENT: ab02a

SENT: 58e325fbda0f540ef781829aedebdad150480fd0Lore m ipsum dolor sit amet, consectetuer adipiscing elit, <cropped> ad minim veniam, quis nostrud exer

I got disconnected, then on reconnect after all the beautiful SSL stuff, I got this:

RECV: userExoduse6ddbc2848e5a8a18d8718d966cb0be8ed7c2ba5

Greek to me, help to you guys?

Ooh - just found a spot that this becomes a little more concerning - when in plaintext, the limit is 1250…but when using 1024-bit OpenPGP encryption, it drops to somewhere between 450-500 characters. I haven’'t pinpointed the tipping point yet, but will if it would help.

Hey Justin,

I tried to reproduce the problem using Pandion, Exodus, Psi and Smack and in all cases I didn’'t have any success. I tried using a normal connection and a secure connection and the connections remain always active.

Could you try running the client and the server in the same computer? My best guess is that something (a firewall or something else) may be killing the connection because of the packet size. Jive Messenger does not have a limit and I cannot reproduce the problem.

Regarding the forbidden error that you mentioned, could you check your Resource Policy configuration in the Admin Console? It seems that you are denying new connections if there is a resource conflict.

Regards,

– Gato

Looks like you hit the jackpot - running a client on the server machine, I can send messages as big as I want - quit trying larger at 50000 chars. Apparently it’‘s not a server issue. However, this still doesn’‘t tell me why I can’'t send large messages from other clients - any ideas? I tried it after disabling Zone Alarm, no dice. Thanks again!

Oh - about the resource settings - I have it set at a kick value of 3.

Hey Justin,

I think that your best bet is to check with your IT department to find out the responsible for the limit in your network architecture. I tried in our local network and it worked fine with a body of 4K.

When you configure the Resource Policy to Assign kick value with a value of 3 it means that if you try to establish a connection using an already connected resource then the new connection will be denied with a forbidden error until the third retry.

Regards,

– Gato

Hmm. I’‘m a little stumped - there’‘s two guys in our IT dept, and I’‘m one of them. It doesn’‘t even appear to be the network, as we determined that he’'s able to send large-bodied messages to me. Apparently the only problem is on my machine, sending out…strange.

My machine is running WinXP Pro SP2…I also tested this in a SuSE 9.2 virtual machine using kopete - no problems, sent over 10k character message. Anybody know what setting could be causing this issue?

I’‘m definitely not an IT expert so I’'m shooting in the dark here. Suspiciously the 1500 limit is close to the default MTU value. So, is it possible that changing the MTU may fix this problem???

Regards,

– Gato

And we have liftoff! My MTU size was set to 1492 - dropping it to 1472 cleared it right up. I just sent my boss the entire U.S. Constitution, so I think we’'re good to go. Thanks a bunch!

  • JustinP