powered by Jive Software

MINA 2.x for Openfire?

Has anyone considered moving Openfire to MINA 2.x?

A few times I was googling about MINA 1.1.7 issues and most responses tend to say “it’s old, not supporterd, no wonder it breaks”. At the same time, I am not sure whether MINA 2.x brings any performance improvements to the table. All I could find was that it simplifies usage and is slightly incompatible with MINA 1.1, therefore requiring some effort to upgrade.

Any thoughts whther it makes sense to spend some time upgrading? I would spend some time on this, but I want to make somebody else hasn’t dodne this already and decided against it.

http://issues.igniterealtime.org/browse/OF-421 has more details, including Guus’ preference on this.