powered by Jive Software

"Missing acknowledge on room creation"

I am trying to implement a code that enables users to create multi user chat rooms on my Android application.

I am using following code to create a new MUC room.

MultiUserChat mucx = new MultiUserChat(connection, roomName + “@” + serviceName);

try {

mucx.create(nickName);

} catch (XMPPException e) {

Log.e(TAG, "Error on MultiUserChat.create ", e);

return false;

}

Form f = new Form(Form.TYPE_SUBMIT);

try {

mucx.sendConfigurationForm(f);

} catch (XMPPException xe) {

Log.e(TAG, “Error on sendConfigurationForm”, xe);

}

When the MultiUserChat.create() method is called, a presence info is sent to the new room and a presence packet is received from the server as follows.

D/SMACK(17765): 05:03:40 PM SENT (1096879600):

D/SMACK(17765): 05:03:40 PM RCV (1096879600):

After that, Smack sends a presence of type unavaiable and throws an exception with message “Creation failed - Missing acknowledge of room creation

D/SMACK(17765): 05:03:40 PM SENT (1096879600):

E/XMPPManager(17765): Error on MultiUserChat.create

E/XMPPManager(17765): Creation failed - Missing acknowledge of room creation.:

E/XMPPManager(17765): at org.jivesoftware.smackx.muc.MultiUserChat.create(MultiUserChat.java:379)

Looking at the source code, it seems that this error is given when the room already exists. But I am sure that the room does not exists, since I check the room list each time. I also tried the same code with other public xmpp servers but no change. So what can be the reason for this error?

Thanks

I’m in a hurry right now, so I can’t verify, but the process that you are using is not the one documented here: http://www.igniterealtime.org/builds/smack/docs/latest/documentation/extensions/ muc.html

Thank you for your interest.

I tried the same code in the link but the result is the same. In fact the only difference on my code is that I am sending an empty form. The exception is thrown right after MultiUserChat.create() call, so the form isn’t submitted yet.

I noticed that the presence received from the server has the status code 110 but the create method waits for 201.

**http://xmpp.org/registrar/mucstatus.html
**

just look at this thread as blow: