powered by Jive Software

Missing components

Hi. I noticed that the jar that was being built is now way smaller than what it used to be … and it turned out that the org.xmpp classes are not included. How come? Am I missing something or do we now have to extract the classes from the openfire source ourselves and create another library for it?

Hopefully it is not the latters thanks!

To solve my problem for the meantime, I added “org/xmpp/*/.class” to the include in the “jar” target of the build file.

We have a similar issue. It appears that the libs in the ‘merge’ directory are no longer merged with the whack jar file. We used to have a whack-full.jar build, that did include them.

Hrm yeah it’s definitely possible that i missed something that was supposed to be built in. I had to change the build.xml quite a bit to make it actually build a releasable library. =D Is there a point in having the non-full version that used to exist?

Hmm … unless you guys have just the xmpp classes readily available in a package somewhere, I think having the full version around will make things easier for whack developers =)

Adding the xmpp classes to the build seems to be a good answer.

For what it’s worth, here is the svn diff for the build.xml

svn diff build.xml Index: build.xml
===================================================================
--- build.xml     (revision 10694)
+++ build.xml     (working copy)
@@ -136,7 +136,7 @@
     <target name="jar" depends="compile" unless="jar.uptodate" description="Produces whack.jar">
         <jar destfile="${jar.dest.dir}/whack.jar"
             basedir="${compile.dir}"
-            includes="org/jivesoftware/whack/**/*.class"
+            includes="org/jivesoftware/whack/**/*.class,org/xmpp/**/*.class"></jar>
     </target>

Still seems the website release is broken. I just downloaded from

http://www.igniterealtime.org/downloads/index.jsp#whack

and it still is missing the org.xmpp classes