Missing feature to configure base-url for admin interface

Hi !

I am new to Openfire. What I am missing is, to use another url for the admin interface, like


Is there any way?

I found nothing in the large configurable property list.

I have apache on the box [debian] and tried to use ether, the url-proxy

and/or/both the mod-rewrite. With my current knowledge not manageble.

Any help would be great!



The admin interface is a simple web server listening on port 9090 and 9091(ssl). You can setup apache to forward like so:

ProxyPass /admin
ProxyPassReverse /admin


Message was edited by: Daryl Herzmann, I am wrong :slight_smile:

Hi !

Much thanks!

Now, wondering why my attempt failed … :frowning:

I’ll try this again.

In the meantime, I came to another solution:

RewriteEngine on
RewriteRule /openfire/(.*) http://server.dom.net:9090/$1

Thanks anyway!!


Hi !

I just gave it a try:It does NOT work!

The initial request is re-directed properly, but all

followers are failing. So, even the initial request

shows the admin page in another way [missing

images etc.]

The way I dicovered and pointed out in my answer,

works good.


Same here!

We really need a solution too!

I think the only option is to setup an apache vhost and since openfire has lots of “/” references, that will point back to the vhost nicely.