powered by Jive Software

Mobile client choices


#1

What are people using (iOS) that is reliable and stays connected in the background on an iOS device? The few I have tried either don’t work most of the time (IM+) or send duplicates of every message (Monal) or don’t stay connected unless the app is on the screen (if you lock the phone it loses the connection after 10 minutes).


#2

XMPP is not very popular on iOS. You can try a few more options from this list https://xmpp.org/software/clients.html


#3

There is ChatSecure but OpenFire does not support all XEP’s it wants. I have a kind of mixed experience with it unfortunately.


#4

Unfortunately the lack of development in resolving the push notification issue in Openfire really hinders it from becoming a top tier platform. With so much mobile connectivity these days it’s almost a requirement. I’ve been struggling to find a suitable Openfire replacement but with the lack of push support it’s becoming a higher priority. Hopefully Openfire can find the resources to implement sooner than later.


#5

@Guus did some work on push recently, although this is still an early version https://github.com/igniterealtime/openfire-pushnotification-plugin

About resources though. It is an open source project with a few volunteers.


#6

I understand that, and for what resources are available it’s a great product and I recognize and appreciate the efforts of all involved. If there is flexibility to direct the resources available to this I think it would be a big benefit overall to Openfire.


#7

I’d love some feedback on that plugin…


#8

I’d be more than happy to provide feedback on it. It’s a feature we’ve been waiting quite some time for. Is there a plugin I can download and implement as of now?


#9

Ok I was able to compile it (one of our devs did it for me). Is there any setup or do I need to reboot or should it just work?


#10

FYI, I ran the ChatSecure mobile app (iOS) and it still reports 357 as not supported in the app.


#11

Ah, you could have simply downloaded the plugin from our website.

Although push notifications are not working for other reasons (working on it), I do see ChatSecure detecting the 357 support.

Initially, I got this:

After a restart, ChatSecure was more or less happy:


#12

Yep, a restart shows it’s compliant now, but it’s not actually working (as you mentioned). Post up when you have an update and I’ll be happy to test.