powered by Jive Software

Moitoring Service Plugin No Data

Hello there,

I am preparing to migrate our users to a new server, from 4.0 on centos 6 using the embedded-db to 4.2 (current) on debian 9 using mariadb. I have installed openfire and connected it up to the database. everything seems to be going well but I noticed that the monitoring service plugin has stopped working. when I open the Statistics page everything comes up blank, as if it’s not collecting any data and the png files (graphs) are not being generated because of this.

I have already tried removing the plugin from the ui and completely removing it’s files and directories from the filesystem, then reinstalling it. Same result. I did notice though that the monitoring directory is showing up in the root openfire directory and not under plugins… i will actually try moving it to plugins and reloading. If that solves my problem I’ll update this… i have so many other plugins installed which properly show up in the plugins directory though.

Let me know if you’d like any more info and thanks in advance.

It is normal for monitoring directory to appear in the root directory (not sure if it was intended, but it is doing this on my side starting with the very first version of this plugin). It holds some indexing files, not the actual plugin’s files.

This turned out to be a non-issue. Thanks for the reply wroot.