powered by Jive Software

Monitoring/archiving disappeared and turned off

I’m running 3.7.1 because 3.8 doesn’t seem to support monitoring.

I manually flushed portions of the chat archive in the MySQL database I run it from, and now the archiving/monitoring service doesn’t seem to work. It’s not saving chats and the links disappeared. All I did was perform a simple query and delete entries that are old.

Is there something I can do to fix this?

I feel like you guys hate me no love?

maybe try uninstalling the monitoring plugin, and then reinstall it. this might get it to rebuild your damaged database.

How did you delete records? altering the tables directly isn’t really advises, since there is cacheing and other magic going on that can be disrupted. Did you do a truncate, delete, or what?

I did a delete. Anything I can do to resolve this?

id first do a mysql dump to a file before going any further…

and for starters… have you tried restarting the openfire service/server to see if it will read the table from there?

I have not looked at the table you are refering too, but my thoughts are perhaps there is a date or some record identifier that openfire is looking for and is now gone… so it freaks out and doens’t know what to do with the data…

after you did your mysql dump, try uninstalling the plugin and reinstall. this will either do nothing, fix your tables, or re-create new ones. if it creates new ones, you can try to insert your old data back in… not an ideal solution of course…

Also, I have no idea if it will do anything, but there is a “rebuild search index” on the archiving tab’s page. give it a go maybe – after creating a mysql dump!

I’ll try those, but the problem with your last suggestion is as of right now, the archiving tab disappeared! Crazy, right?

hmm… ya, definetely sounds like the plugin is bonked out now… I would definetely do a mysql dump then uninstall/reinstall the plugin… should get things back to working state… only question will be will it preserve your data in the process or wipe it and start over… if it does, you’ll have a fun time inserting your old data from the mysql dump lol…

First post !

I have had openfire running problem free till the update , then i got the no archives , so i tried the beta . then i got the no archive screen .

so i rolled everything back , thank GOD i backed up the database before .

now all is good , i will sit and wait till others say update is stable before i try this again .

http://issues.igniterealtime.org/browse/OF-611