Monitoring plugin

Since installing OF 4.0.2 the server stopped archiving messages. I have updated to the latest version (1.5.1) of the Monitoring plugin and still no success. Has anyone come across this yet, or have a suggestion for a fix?


Hi Steve,

We have the same issue, I open a discussion with the same question but no one here in community would like to answer our question. I think this is a bug of OF 4.0.2. @wroot this is what I’m telling you before. I hope someone could fix this issue.

I have filed this as OF-1144

Can’t do anything else. I don’t use monitoring and it is known to have various issues all the time (one reason why i won’t use it if i even need it). Nobody has replied to your discussion as this is strictly a volunteer driven community. So not many are visiting this forum or have time to investigate every issue and fix it.

You can provide any related errors you find in the logs.

Thanks. Are you able to access any of your archived messages? I can see everything up to the date I did the upgrade, then nothing. I will keep looking. If I get this resolved, I will let you know.

It seems I may have found my answer. It seems the issue is with XAMPP and MySQL.

I was looking through the MySQL error logs and saw several errors pointing to InnoDB… in the MySQL my.cfg file.

I tried to add innodb_force_recovery = 1 to have it force the InnoDB tables to load. This created many more errors (close to 2M over the time that I had this set.)

I decided to comment this line and the next few innodb lines (all prior to the “you can set …_buffer_pool_size …). After this I did a reboot to make sure all services were restarted that needed to be. This time MySQL started OK and I sent a test message in Spark. I then logged into the OpenFire admin interface and went to Server>Archiving>Search Archive. Once I clicked on the search button the new message appeared in the list of archived messages.

This may not be the best fix, but it is working for me…for now.

I rechecked the MySQL error log and see a new message.

InnoDB Warning: Using innodb_additional_mem_pool_size is DEPRECIATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB’s internal memory allocator.”

Since this may be removed in future releases, I decided to let it run like this for a while and see how it holds up.

Fingers crossed.

1 Like