powered by Jive Software

Monitoring Service 1.6.1 broken


#1

Hi,

after Upgrade this plugin to 1.6.1 i cant access the sites:

http://192.168.x.x/plugins/monitoring/stats-dashboard.jsp

and

http://192.168.x.x/plugins/monitoring/archive-search.jsp

HTTP Error 404

error log says:

2018.07.06 14:24:41 org.jivesoftware.openfire.container.PluginServlet - An unexpected problem occurred while attempting to register servlets for plugin ‘org.jivesoftware.openfire.plugin.MonitoringPlugin@79caebd6’.
java.lang.NoClassDefFoundError: org/apache/jasper/runtime/JspSourceImports
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:763)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:467)
at java.net.URLClassLoader.access$100(URLClassLoader.java:73)
at java.net.URLClassLoader$1.run(URLClassLoader.java:368)
at java.net.URLClassLoader$1.run(URLClassLoader.java:362)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:361)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
at org.jivesoftware.openfire.container.PluginManager.loadClass(PluginManager.java:958)
at org.jivesoftware.openfire.container.PluginServlet.registerServlets(PluginServlet.java:151)
at org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.java:568)
at org.jivesoftware.openfire.container.PluginMonitor$MonitorTask$4.call(PluginMonitor.java:276)
at org.jivesoftware.openfire.container.PluginMonitor$MonitorTask$4.call(PluginMonitor.java:264)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.ClassNotFoundException: org.apache.jasper.runtime.JspSourceImports
at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
… 20 more

thx!

Erik


#2

My first guess is that this version of the monitoring plugin is not compatible with whatever version of Openfire you’re using. We typically check for these things, but maybe we missed something. What version of Openfire are you using?


#3

I’m actually having a problem as well - we recently upgraded to 4.2.3, and then upgraded the monitoring plugin to 1.6.1, and can’t get the Statistics or Archiving tabs to load, both give a 404 HTTP Error.

Edit: I cleared the Error log, and restarted the monitor plugin. I get the same error message as Erik7.


#4

You should also provide info about OS and Java you are using.


#5

I’m using Windows Server 2012 R2, with Java 8 Update 171 64-bit. Openfire is also 64-bit. I just found and downloaded the 1.6.0 version of the plugin from the Beta Plugin Page, and that seems to be working.

The Statistics page is blank, and generates an error "2018.07.06 09:09:14 org.jivesoftware.openfire.container.PluginServlet -
java.lang.NullPointerException " - but the reports show data, and I can pull up and search the archive again.


#6

Monitoring plugin on my test server wasn’t updated to 1.6.1 yet (it was a very recent release). But once i have updated, i can’t access Statistics page either. Although i don’t get the 404 error, just a blank page. But i see that error in the logs:

2018.07.06 21:51:19 org.jivesoftware.openfire.container.PluginServlet - An unexpected problem occurred while attempting to register servlets for plugin ‘org.jivesoftware.openfire.plugin.MonitoringPlugin@5909bbaa’.
java.lang.NoClassDefFoundError: org/apache/jasper/runtime/JspSourceImports
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.security.SecureClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.access$100(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at org.jivesoftware.openfire.container.PluginManager.loadClass(PluginManager.java:958)
at org.jivesoftware.openfire.container.PluginServlet.registerServlets(PluginServlet.java:151)
at org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.java:568)
at org.jivesoftware.openfire.container.PluginMonitor$MonitorTask$4.call(PluginMonitor.java:276)
at org.jivesoftware.openfire.container.PluginMonitor$MonitorTask$4.call(PluginMonitor.java:264)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: org.apache.jasper.runtime.JspSourceImports
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)


#7

Filed as https://issues.igniterealtime.org/browse/OF-1568
This might be a fail of recent change how plugins are built in Bamboo system and not specifically the last change to code.


#8

Thank you guys, and thank you Erik7 for posting it - I came on the forums this morning to find an answer, and got lucky and ran across your post right away. 1.6.0 works for the most part, at least the archiving does, and that’s the most critical for me.


#9

I have reverted the monitoring plugin version available on the website to 1.6.0 until this issue is resolved.


#10

1.6.0 work for me just fine.


#11

I note the parent plugin for Monitoring is Openfire 4.3.0-SNAPSHOT. I suspect it will be necessary to drop that to 4.2.0

Greg


#12

I got a same error log when installing RestAPI 1.3.3 on Openfire 4.2.3, and config page /plugins/restapi/rest-api.jsp also return 404.

The worst thing is both authentication methods are not working, anyone can access any endpoints.


#13

Filed as https://issues.igniterealtime.org/browse/OF-1572


#14

restapi 1.3.1.jar (3.4 MB)


#15

I have placed this version on the website.