Monitoring Service Plugin

Chaps,

I have the Monitoring Service plugin running on Openfire 3.6.4 (sitting on win2k3, mysql), but for some reason, a lot of the conversations come up with “The messages in this conversation were not archived.”

Are there any issues with different char sets? The conversations are often in cyrillic as well as other char sets

I suspect this to be down to the collation of your MySQL database, can you post your current db settings?

Which settings would you like? my.ini?

by the way, the char set there is - default-character-set=utf8

This is what the SHOW VARIABLES LIKE ‘character_set_%’;

mysql> SHOW VARIABLES LIKE ‘character_set_%’;

±-------------------------±-------+

| Variable_name | Value |

±-------------------------±-------+

| character_set_client | utf8 |

| character_set_connection | utf8 |

| character_set_database | utf8 |

| character_set_filesystem | binary |

| character_set_results | utf8 |

| character_set_server | utf8 |

| character_set_system | utf8 |

±-------------------------±-------+

7 rows in set (0.00 sec)

come back with

±-------------------------±-------+

| Variable_name | Value |

±-------------------------±-------+

| character_set_client | utf8 |

| character_set_connection | utf8 |

| character_set_database | utf8 |

| character_set_filesystem | binary |

| character_set_results | utf8 |

| character_set_server | utf8 |

| character_set_system | utf8 |

±-------------------------±-------+

7 rows in set (0.00 sec)

These vars are server-wise, can you grab information for your Openfire database, please

EDIT

I think i found it -

| ofmessagearchive | MyISAM | 10 | Dynamic | 132934 | 109

| 14516320 | 281474976710655 | 2270208 | 0 | NULL |

2010-02-22 21:48:44 | 2011-01-21 21:51:42 | NULL | latin1_swedish

The message archive table had encoding different from the rest of the tables in the db

-------------------

HI, these are the settings for the openfire db specifically

C:\Program Files\MySQL\MySQL Server 5.0\bin\mysql.exe Ver 14.12 Distrib 5.0.87,

for Win32 (ia32)

Connection id: 47

Current database: openfire

Current user: root@localhost

SSL: Not in use

Using delimiter: ;

Server version: 5.0.87-community-nt MySQL Community Edition (GPL)

Protocol version: 10

Connection: localhost via TCP/IP

Server characterset: utf8

Db characterset: utf8

Client characterset: utf8

Conn. characterset: utf8

TCP port: 3306

Uptime: 15 hours 39 min 59 sec

Threads: 8 Questions: 294495 Slow queries: 2 Opens: 708 Flush tables: 1 Ope

n tables: 13 Queries per second avg: 5.222


C:\Program Files\MySQL\MySQL Server 5.0\bin\mysql.exe Ver 14.12 Distrib 5.0.87,

for Win32 (ia32)

Connection id: 47

Current database: openfire

Current user: root@localhost

SSL: Not in use

Using delimiter: ;

Server version: 5.0.87-community-nt MySQL Community Edition (GPL)

Protocol version: 10

Connection: localhost via TCP/IP

Server characterset: utf8

Db characterset: utf8

Client characterset: utf8

Conn. characterset: utf8

TCP port: 3306

Uptime: 15 hours 39 min 59 sec

Threads: 8 Questions: 294495 Slow queries: 2 Opens: 708 Flush tables: 1 Ope

n tables: 13 Queries per second avg: 5.222


There you go, Latin1 will have issue with Cyrillic characters. You can change that collation to match the rest of them, but I suppose in your case UTF-8 or similar will be most appropriate (below collation I use):

ALTER TABLE ofMessageArchive COLLATE utf8_general_ci

looks ok with new messages so far (in cyrillic so far), old messages are still unavaliable. going to play about some more but at least there’s some progress

great stuff, I’m afraid there is no way to get old messages as they were probably not stored due to collation issue, at least you should be sorted from now on

I’m having this exact same problem.

I have set everything to UTF8, but it still won’t archive Cyrillic (and other non English) chat.

I’ve altered the whole database, every table in it and the MySQL server that it runs on, but still no go…

Any help would be appreciated.

Fixed.

I had to convert the database, change the default startup encoding, reboot MySQL and then convert the tables.

Message was edited by: Valsimot

I just noticed that the pdf transcript (that is sent to users) still doesn’t contain Cyrillic (and other non English) letters while the log does… Anyone else have this problem?

Thanks.

Nevermind, ticket already exists OF-404… Hopfully this will be fixed soon…