More Fastpath Webchat problems

We’'ve got the webchat mostly working. Now we are trying to get rid of an additional problem.

This seems to only be a problem when using Internet Explorer and SSL. When you first launch the browser and go to initiate a support chat (as the end user) it places you in the queue. This pops on the agent side and they have the chance to accept / reject. (So far so good) When the agent accepts the session, however, it is not changing the window on the web chat client side. It leaves them in a spinning waiting for an agent to answer state.

We have the problem on some machines using IE and some machines using IE we don’'t, it seems to be very hit and miss.

Checking the admin-console.log when this happens we see this error message everytime…

16:11:18.926 WARN!! [SunJsseListener1-4] org.mortbay.http.HttpConnection.exception( >06> POST /webchat/dwr/exec/room.getChatQueue.dwr HTTP/1.1 HttpException(400,Bad Request,Missing Content)

If we connect to the chat without SSL (by changing the link that we are connecting to) then it seems to work fine. I have checked the chat-settings.xml file and it seems to have the SSL ports defined and enabled correctly.

Also another thing that we tried is not using our own certificate, but, using the certificates that come with the default install. We experience the same problem with those certificates.

Thanks for any ideas.


Hi Thad,

I’'ve been corresponding with Kevin in the forums on, but we are trying to migrate Fastpath forums over here so this is a better forum to discuss this in. I found a couple of bugs in IE which might match your situation:

By the way, which version of IE is this with?



I saw the conversation going on in the other forums. The only reason I posted here is because he was not getting a response over there. One of the IE versions that we are experiencing this problem on is 6.0.2900.2180.xpsp_sp2…

Ironically, we have an identical version of IE on another computer that works just fine.

I tried the test.html with test.xml referenced in the first link and didn’'t see the error that the link says I should.

In regards to both of these links, we are running a newer version of IE than they say it affects.



Still no idea on this problem?

Hi Thad,

Unfortunately we have not been able to reproduce the problem. Have you found any patterns to the machines that don’'t work?



The only possible thing that we have noticed may be different is that computers that appear to have or previously had the Microsoft VM. Computers that have the Microsoft VM don’'t seem to work properly. Also any computers that had the MSVM and it was now removed, also experience the problem.

Edit: This was already mentioned in the thread on the forum.