powered by Jive Software

Moving openfire 3.7.1 from a server to a new one (with of 4.1.4) WITH pidgin (2.10.3)

I’m facing a great issue doing what I wrote in the title.

So first you need to know that I have clients databases on a remote server. I have openfire (old version) on another server. And openfire (new version) installed on another version.

Now Im trying to link my new openfire to the database (where mt clients are registered) and then I’ll try to configure pidgin.

You may ask: what is the problem?

You link your openfire to the database directly, and work done.

But it wasnt thaat easy. When I did install new openfire on the server and attached it to the database, I couldn’t log with my old admin account.

So I created a new database. With a new admin and it worked.

I tried to change then the database location in conf/openfire.xml but it didnt work.

Worst, it changed the configuration of my old openfire and I had to remove what I did to give access again to pidgin to my clients. (Happened because of the admin of my old database… not sure).

Anyway, Im stuck, completly…

Has anyone faced this issue? How can I fix this? Is there a problem because of compatibility between an old version database and a new? I really dont know what to do…