powered by Jive Software

MS SQL 2005 Express woes

Looked through posts but cant find solution to my problem, starting to drive me up the wall

When trying to apply Database Settings I get the error: A connection to the database could not be made…Log file is…

2009.12.10 14:28:11 [org.jivesoftware.util.log.util.CommonsLogFactory$1.error(CommonsLogFactory.jav a:92)] Prototype
java.sql.SQLException: Unable to get information from SQL Server: SSUIMS001.
at net.sourceforge.jtds.jdbc.MSSqlServerInfo.(MSSqlServerInfo.java:91)
at net.sourceforge.jtds.jdbc.ConnectionJDBC2.(ConnectionJDBC2.java:276)
at net.sourceforge.jtds.jdbc.ConnectionJDBC3.(ConnectionJDBC3.java:50)
at net.sourceforge.jtds.jdbc.Driver.connect(Driver.java:182)
at java.sql.DriverManager.getConnection(Unknown Source)
at java.sql.DriverManager.getConnection(Unknown Source)
at org.logicalcobwebs.proxool.DefaultConnectionBuilder.buildConnection(DefaultConn ectionBuilder.java:39)
at org.logicalcobwebs.proxool.Prototyper.buildConnection(Prototyper.java:159)
at org.logicalcobwebs.proxool.Prototyper.sweep(Prototyper.java:102)
at org.logicalcobwebs.proxool.PrototyperThread.run(PrototyperThread.java:44)
2009.12.10 14:28:11 [org.jivesoftware.database.DbConnectionManager.setConnectionProvider(DbConnecti onManager.java:501)]

Database URL is: jdbc:jtds:sqlserver://SSUIMS001/OpenFire;appName=jive;Instance=SQLEXPRESS

SSUIMS001 is my PC name. Im running SQL Express 2005 with the SQL Server Management Studio Express.

I have followed the documentation, created a new database called OPENFIRE, new login with access rights, opened the openfire_sqlserver.sql file and done the query pressing F5 to create tables.

It’s using default port 1433.

I’ve tried many variations of the URL, adding port, changing instance to OPENFIRE, putting SSUIMS001\SQLEXPRESS for host name

No idea if it should make a difference, but my SQL is installed to a different location than default (E:\Microsoft SQL Server)

Anyone got any ideas I could try?

Thanks

you have to set your sql instance port from dynamic to something static. If its the only instance on the server, than you can use the default port of 1433. If its not the only sql instance, than you may want to use something else, like 2433.

then your connector setting should go like this. notice the (:slight_smile: after the port number!! very important!

jdbc:jtds:sqlserver://SERVER_NAME:PORT#:/INSTANCE_NAME;appName=DATABASE_NAME

heres mine

jdbc:jtds:sqlserver://server1:2433:/sqlexpress;appName=openfire

Thanks for quick reply!!

Deleted all Dynamic port settings (were on 0 by default) and under IPALL put TCP Port as 1433. Used the line you gave and got the following

2009.12.10 15:29:05 [org.jivesoftware.database.SchemaManager.checkSchema(SchemaManager.java:228)]
java.sql.SQLException: CREATE TABLE permission denied in database ‘master’.

Above means that its getting much further so now a permission issue, so changed my logon details from custom one i made to sa account and its got to the next stage!!!

Thanks Speedy! Spent about 9 hours on this and it turns out to be something relatively simple (when you know where to look)