MSN Transport Connection Troubles

I’m running openfire 3.4.4 because 3.4.5 is not in gentoo’s portage system yet, but I’m running the most up-to-date version of the Gateway plugin. I am experiencing “flickering” connections to MSN. Intermittently, users’ MSN connections will go offline and then come back online dozens of times per minute. When I disabled mail notifications and buddy icons, the issue seems to be resolved. Is this a known issue? I tried searching the forum and couldn’t find any reference to it.

Buddy Icon support would be much appreciated by my users, but not at the cost of their connectivity.


I’m having a similar problem with one client, we’ve only just started using Spark (2.5.8)/ Openfire (3.4.5) Gateway (1.2.2a) got about 5 users on it at the moment, and one user is experiencing problems where he is repeatedly logged out / in of MSN, to the extent that he’s had to go back to using the MSN client instead.

Any ideas to try ?

Rick, I recommend disabling buddy icon support in the MSN Gateway options on the openfire server. That seems to have been a workable temporary fix for me.

Thanks, having read the same in a few more topics I did just that, and so far I’m not seeing any reconnects in the debug log.

Bit of a shame, they haven’t said anything yet but I’m sure I’ll get complaints once they realise the Icons are missing !

I do have some good news. =D There was a patch applied to JML recently that I think may be the culprit. Basically, when avatars were retrieved, it happened in the same thread as everything else. So if you are waiting on an avatar to be downloaded, JML (and hence the IM Gateway plugin) can’t actually respond to, oh, pings and stuff from MSN. I suspect that that’s why people are getting booted, JML isn’t being as responsive as it should be to MSN itself and so MSN says “get out”. The fix for this will be in 1.2.3. (1.2.3 will require an upgrade to Openfire 3.5.0 though, fair warning)

Awesome, that’s very exciting. I was guessing it was something like that. Unfortunately I’ve been installing Openfire via the gentoo portage system, so it might take a while for them to get around to publishing an ebuild for the new Openfire. I guess we’ll see what happens. Thanks much for your helpful answer!


I have openfire 3.5.1 with gateway 1.2.3 and the user get up and down all the time with transport for msn.

Any idea?


I suggest that you disable Buddy Icons, this fixed the problem for me.


Every 5 minutes or so I’d be disconnected and reconnected until I disabled Buddy Icons.

I will send this problem and this solutions on the openfire’s Brazil list and another users have the same problem.

Thank’s for your help.