MSN Transport: Login fails (Undefined condition)


I just set up a new Openfire server (3.5.2) on a virtual server running debian etch.

Everything works fine except of the MSN transport. The connection test passes as well as the registration process. But when I try to log in the following message pops up after a few seconds:

Undefined condition.
The error condition is not one of those defined by the other conditions in this list.

You have been disconnected from MSN

I ran Openfire on a different machine before (also Debian based) and the transport worked fine.

Anybody got an idea what could be wrong?

Thanks in advance…!

I forgot the debug log that says…


008.08.26 18:04:27 MSN: Exception occurred for : org.jivesoftware.util.SimpleSSLSocketFactory
2008.08.26 18:04:27 MSN: IO error: org.jivesoftware.util.SimpleSSLSocketFactory
2008.08.26 18:04:27 Disconnecting session user@mydomain.tld from msn.mydomain.tld

Ok, this is interesting. Adding the property

xmpp.client.idle = -1

solves the problem.

I needed it for a different purpose.