powered by Jive Software

MUC causing Spark to crash

Hello,

After upgrading to 4.7.1 our group chats no longer work. when trying setup adhoc meetings spark crashes indicating “a connection error has occurred”. Tested on various versions of spark, crashes each time. Only change made was updating Openfire from 4.6.2 to 4.7.1

Openfire logs indicate: (changed only instance specific names & ip.)

WARN [Server SR - 27706593]: org.jivesoftware.openfire.net.SocketReader - Closing session due to incorrect hostname in stream header. Host: hostname. Connection: org.jivesoftware.openfire.net.SocketConnection@20ce4070 socket: Socket[addr=/xxx.xxx.xxx.xxx,port=xxxx,localport=xxxx] session: null
2022.03.07 14:26:23 WARN [pool-5-thread-8]: org.jivesoftware.openfire.session.LocalOutgoingServerSession[Create outgoing session for: {hostname.local -> hostname] - Unable to create a new session: exhausted all options (not trying dialback as a fallback, as server dialback is disabled by configuration.
2022.03.07 14:26:23 WARN [pool-5-thread-8]: org.jivesoftware.openfire.session.LocalOutgoingServerSession[Authenticate local domain: 'hostname.local' to remote domain: 'hostname'] - Unable to authenticate: Fail to create new session.
2022.03.07 14:26:23 WARN [pool-5-thread-8]: org.jivesoftware.openfire.server.OutgoingSessionPromise$PacketsProcessor - An exception occurred while trying to establish a connection for {hostname.local -> hostname}
java.lang.Exception: Failed to create connection to remote server
    at org.jivesoftware.openfire.server.OutgoingSessionPromise$PacketsProcessor.establishConnection(OutgoingSessionPromise.java:309) ~[xmppserver-4.7.1.jar:4.7.1]
    at org.jivesoftware.openfire.server.OutgoingSessionPromise$PacketsProcessor.run(OutgoingSessionPromise.java:252) [xmppserver-4.7.1.jar:4.7.1]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [?:1.8.0_202]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [?:1.8.0_202]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_202] 
	
	
	
	2022.03.07 14:52:57 ERROR [socket_c2s-thread-6]: org.jivesoftware.openfire.nio.ConnectionHandler - Closing connection due to error while processing message: <presence to='user@conference.hostname.local/User' id='EAXyK-2582'><x xmlns='http://jabber.org/protocol/muc'></x><c xmlns='http://jabber.org/protocol/caps' hash='sha-1' node='http://www.igniterealtime.org/projects/smack' ver='9LJego/jm+LdNGOFm5gPTMPapl0='/><x xmlns="vcard-temp:x:update"><photo>b83105fa4fafb31c6de32a0c240034482181e547</photo></x><x xmlns="jabber:x:avatar"><hash>b83105fa4fafb31c6de32a0c240034482181e547</hash></x></presence>
java.lang.IncompatibleClassChangeError: Found class org.jivesoftware.openfire.muc.MUCRoom, but interface was expected

I am not sure if this explains the crash of Spark, but the very last line of your logs indicate that Openfire has a plugin that is outdated. Please verify that all of the Openfire plugins are updated, and see if the problem persists.

Thanks for the quick response guus, are you able to tell which plugin? we tried that but it was showing that everything was updated.

we even tried to manually update plugins that we thought could be related, but issue persisted. we were forced to revert back to an older snapshot as our users rely on MUC’s heavily.

Thanks

I can’t tell that from these logs. Typically, it’s the Monitoring plugin, but it could be others.

This was the plugin that we were focused on the most, we updated it, used older version, tried to run without it. no changes.

All other plugins were up-to-date yet issue persists.

We are weary to update again, has anyone else reported this?