powered by Jive Software

Multi User Chat not working in 12-19-2004 build

Hello,

I’'ve tried Trillian 3.0, JBother, and Exodus. All can do user-to-user chat just fine, but none have been able to successfully join a MUC.

I’'ve tried a mix of pre-created rooms, on demand chat rooms, password protected, nothing works. Oddly, in the password protected tests, providing the wrong or no password produced exactly the same results (not even a bad password message).

*** ERROR: iq error 404 from conference@bender

What’'s the right way to debug this?

The MUC service should be room@conference.bender and not conference@bender. I think if you try that, it should work fine. Also, Exodus should automatically discover the correct name of the MUC service using disco…

Regards,

Matt

Thanks for the response.

The log message was just one of the numerous examples I’'ve tried.

The error message I happened to have pasted was one where I was trying to use the “Group chat service name” to get a connection. I don’‘t know what this string represents or how a client would use it (I don’'t see anything suggesting usage of this string in either Trillian or JBother – upgrading to latest nightly of Exodus right now). Can someone explain how this field is used and when to change it?

All the users connecting are explicitly listed as able to create rooms on demand. No dice.

thanks!

greg

Using the embedded hsql DB.

Exodus can’'t log in and the server generates this:

2004.12.19 15:08:15 [org.jivesoftware.messenger.handler.IQAuthHandler.handleIQ(IQAuthHandler.java:1 44)

] Error handling authentication IQ packet

java.lang.NullPointerException

at org.jivesoftware.messenger.SessionManager.getSession(SessionManager.java:473)

at org.jivesoftware.messenger.audit.spi.AuditorImpl$AuditPacket.(AuditorImpl .java:233)

at org.jivesoftware.messenger.audit.spi.AuditorImpl.writePacket(AuditorImpl.java:1 09)

at org.jivesoftware.messenger.audit.spi.AuditorImpl.audit(AuditorImpl.java:77)

at org.jivesoftware.messenger.net.SocketConnection.deliver(SocketConnection.java:1 91)

at org.jivesoftware.messenger.handler.IQAuthHandler.handleIQ(IQAuthHandler.java:10 1)

at org.jivesoftware.messenger.handler.IQHandler.process(IQHandler.java:53)

at org.jivesoftware.messenger.spi.IQRouterImpl.handle(IQRouterImpl.java:126)

at org.jivesoftware.messenger.spi.IQRouterImpl.route(IQRouterImpl.java:58)

at org.jivesoftware.messenger.spi.PacketRouterImpl.route(PacketRouterImpl.java:76)

at org.jivesoftware.messenger.net.SocketReadThread.readStream(SocketReadThread.jav a:204)

at org.jivesoftware.messenger.net.SocketReadThread.run(SocketReadThread.java:109)

Hey Gregory,

Thanks for the bug report. The problem has been fixed. You can download a working version with the next nightly build.

Thanks,

– Gato

I am also having this problem and am using the nightly update from 12/21. Seems that I can create the room but that no others can join. The room does not show up when using the browse in Exodus. Other than that, so far it’'s way better than jabberd.

Hey George,

The problem that was fixed was the one you reported in IQAuthHandler. Are you still having the same error log?

Regarding the problem joining a room I have a couple of questions.

  1. If you are using the latest nightly build you will need to recreate the database since the mucRoom table structure has changed.

  2. How are you creating the room? If you are creating it from the admin console then the room is persistent and should be visible from Exodus or any other client that uses disco. If you are creating a room from a client and the room is not persistent, is the owner of the room still present in the room? Otherwise the room will be destroyed if no one is in the room.

  3. Do you see have any new error in the error.log?

  4. If your problem still persists, can you post the sequence of xml packets sent and received from the server?

Regards,

– Gato

NM, posted too soon. Was able to make a room and have others join. Do not know how to invite or moderate from Exodus though. Seems I only have Block and Un-Block.