My Ofmeet setup finally complete

Again I wish to thank all the kind people that participate here on this site. Although I don’t post often I read through content almost everyday to see what cool things everyone is doing.

During that time I’ve created my own little meeting center and wanted to show it “OF” a bit. (Pun Intended!) Being able to schedule or have “on-the-fly” video meetings instead of costly trips to and from clients is so much more organized and efficient.


Hello Jay,

are you using the 3.9.3 OF version or the beta?

I am using the 3.10 beta on Windows Server 2012R2

Hi Jay,

Can you provide a bit more detail about your setup. The video is nice, but we know what the application looks like. The majority of posts are related to backend setup.

Is this an out-of-box install? or was there some configuration required?

Hi Liam, far from a out of the box install and learned by failure after failure!

Background Scope:

I wanted to be able to video meet clients using my existing hardware, ISP and as much open source software as possible without any additional downloads client side.


Dell T300

Dual Quad core Xeon @ 2.50GHz

Dual GB Nics

24570 MB Total Memory


XenServer 6.5

System OS:

Windows Server 2012 R2 SP2 Enterprise

1 Dual Core allocated CPU

8 GB allocated memory

Installed OpenFire 3.10.0 Beta

Installed Ofmeet 0.1.4 (Started with original JitsiBridge)

created my rooms / users

Tested working on LAN (worked fine)

Setup router for port forwarding of pertinent ports.

Tested WAN as fail, could not connect video or audio over WAN. However browser did connect to server. Important to note that I am using a dynamic external ip.

Further research and I installed the available STUN module to OpenFire. Tested WAN and received same results as above. I then consumed hours of research on these forums and found that NAT transversal was my issue. It seems mentioned many places that unless your server is “Forward facing”, meaning I suppose a VPS of some sort that none of this works right. Back to research since I could not get it to work over WAN and I had NO idea what I was doing!

So to test this NAT issue theory I used a soft VPN (Hamachi) between a laptop off my lan and the server on lan and had success connecting video and audio. One step closer and I had decided that I would have to bundle a zero config vpn client that I could send clients BUT that would expose my internal network and I wasn’t too keen on that. I started my research into soft vpn’s and found Softether VPN by chance. Since my software environment is virtualized and I can roll back I decided to install it. Softether is open source and advertises itself as a strong VPN solution, offers a Dynamic DNS service built in and during setup said “Installing this software will punch a hole through Level NAT Transversal” (BINGO!).

Once installed on the same server as OpenFire and Ofmeet and the required ports needed all worked like a charm. Basically Softether VPN was the glue that allow the audio/video to move in and out of the server. Probably, if given the chance to spend the money in the near future I will be moving it to a cloud VPS but it works for now.


Intermittent audio quality (could be client side & doesn’t happen all the time)

Have not been able to screen share at all

I do not use SIP so have no experience with that side of it

Hope that helps some,


Thanks Jay!

That’s the best I’ve seen from any of the posts. I’ve had exactly the same experience as you and am running a similar stack. STUN was no help and I’m baffled by NAT not working with appropriate rules in place even with reverse NAT in place. I’m using a static IP, and public FQDN for the server. I’ve never had success with NAT other than the in meeting room chat working. I had 1 day of success between my desktop and android device - full video and audio! But have not had any since with zero changes to my config. The last deep dive I took it looked like a conflict between the local FQDN (ie host.local) and the publci FQDN (

The SIP portion works fine but you need at least 2 people in the room for it to dial out which has been a challenge. I’ve also not been able to screen share.

I haven’t had a chance to play with Softether but will look into it.

Thanks Again!

Thanks Liam, two things I remembered after my writing last post.

  1. STUN also made no difference for me.

  2. My initial XenServer version ( I think 6.2 ) was also a nat issue. Seems that the Xen OS couldn’t figure out what to do. When I upgraded with 6.5 that issue did resolve.


Hi Jay,

Thanks for your posts.

I am using openfire 3.10 beta and ofmeet 0.1.4.

Video bridge is working fine but on executing it from candy is creating an issue where partner video is not visible.

It is giving following exception stack trace.

Could you please point out where the problem is.

INFO: before join as

Apr 01, 2015 11:41:00 PM info

INFO: joinAs focus

Apr 01, 2015 11:41:00 PM error


led to join the room Failed to j

oin the room

at org.jitsi.impl.protocol.xmpp.ChatRoomImpl.joinAs(

at org.jitsi.impl.protocol.xmpp.ChatRoomImpl.join(

at org.jitsi.jicofo.JitsiMeetConference.joinTheRoom(JitsiMeetConference.


at org.jitsi.jicofo.JitsiMeetConference.maybeJoinTheRoom(JitsiMeetConfer

at org.jitsi.jicofo.JitsiMeetConference.registrationStateChanged(JitsiMe

at org.jitsi.jicofo.ProtocolProviderHandler.registrationStateChanged(Pro





at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtoc


Caused by: forbidden(403)

at org.jivesoftware.smackx.muc.MultiUserChat.getConfigurationForm(MultiU

at org.jitsi.impl.protocol.xmpp.ChatRoomImpl.joinAs(

… 9 more



Hi Jigar, I’m afraid that’s beyond the scope of my experience. I’ve never had to troubleshoot Java issues or do stack traces. Possibly if you post this as a stand-alone question a expert could help you.



Nice work, Jay! Thanks for sharing.

1 Like

Thanks Jay for your explanation.

I am bit confused when you said

Installed Ofmeet 0.1.4 (Started with original JitsiBridge).

What I know is Ofmeet 0.1.4 plug in can be executed alone to execute the video bridge.

I am executing Candy by following url

https://localhost:7443/ofmeet/candy.html which also provides videobridge integration.

Could you please explain starting Ofmeet 0.1.4 with original JitsiBridge.



Oh sorry, when I originally started my project I was using the Jitsi video bridge plugin that was provided here at Ignite. Since then it’s been updated to ofmeet plugin by Dele and greatly improved in my opinion.

As a update to all of this I moved my system to a dedicated box instead of virtualized in XenServer and now have fully working screen sharing going on. Must of been something with XenServer not passing traffic right.

Candy I have no experience with though.