Need admin priviledge to run spark withi vista professional

With vista professionanle we need to run spark with admin proviledge or it wont connect to the server.

I look at the debug and i see thath the connection to the server has been made and that some info has been send back to spark but spark just keep trying to connect.

I dont have the problem with xp.

Spark version is 2.5.8 and openfire is 3.4.1

We stop windows defender and still it dosen’t work.

What am i missing?

David

Here is a partia dump:

<stream:stream to=“centaure.capitale.qc.ca” xmlns=“jabber:client” xmlns:stream=“http://etherx.jabber.org/streams” version=“1.0”>

<starttls xmlns=“urn:ietf:params:xml:ns:xmpp-tls”/>

<stream:stream to=“centaure.capitale.qc.ca” xmlns=“jabber:client” xmlns:stream=“http://etherx.jabber.org/streams” version=“1.0”>

<auth mechanism=“PLAIN” xmlns=“urn:ietf:params:xml:ns:xmpp-sasl”>AHNkZW1lcnMAZGVtczc3MTg=</auth&g t;

<stream:stream to=“centaure.capitale.qc.ca” xmlns=“jabber:client” xmlns:stream=“http://etherx.jabber.org/streams” version=“1.0”>

<iq id=“DN9EP-0” type=“set”><bind xmlns=“urn:ietf:params:xml:ns:xmpp-bind”><resource>spark</resource& gt;</bind></iq>

<iq id=“DN9EP-1” type=“set”><session xmlns=“urn:ietf:params:xml:ns:xmpp-session”/></iq>

<iq id=“DN9EP-2” type=“get”><query xmlns=“jabber:iq:roster”></query></iq>

<iq id=“DN9EP-3” to=“centaure.capitale.qc.ca” type=“get”><query xmlns=“http://jabber.org/protocol/disco#items”></query></iq>

Received

<?xml version=‘1.0’ encoding=‘UTF-8’?><stream:stream xmlns:stream=“http://etherx.jabber.org/streams” xmlns=“jabber:client” from=“centaure.capitale.qc.ca” id=“d78e61e8” xml:lang=“en” version=“1.0”>

<stream:features><starttls xmlns=“urn:ietf:params:xml:ns:xmpp-tls”></starttls><mechanisms xmlns=“urn:ietf:params:xml:ns:xmpp-sasl”><mechanism>PLAIN</mechanis m><mechanism>ANONYMOUS</mechanism></mechanisms><compress ion xmlns=“http://jabber.org/features/compress”><method>zlib</method></compression><auth xmlns=“http://jabber.org/features/iq-auth”/><register xmlns=“http://jabber.org/features/iq-register”/></stream:features>

<proceed xmlns=“urn:ietf:params:xml:ns:xmpp-tls”/>

<?xml version=‘1.0’ encoding=‘UTF-8’?><stream:stream xmlns:stream=“http://etherx.jabber.org/streams” xmlns=“jabber:client” from=“centaure.capitale.qc.ca” id=“d78e61e8” xml:lang=“en” version=“1.0”><stream:features><mechanisms xmlns=“urn:ietf:params:xml:ns:xmpp-sasl”><mechanism>PLAIN</mechanis m><mechanism>ANONYMOUS</mechanism></mechanisms><compress ion xmlns=“http://jabber.org/features/compress”><method>zlib</method></compression><auth xmlns=“http://jabber.org/features/iq-auth”/><register xmlns=“http://jabber.org/features/iq-register”/></stream:features>

<success xmlns=“urn:ietf:params:xml:ns:xmpp-sasl”/>

<?xml version=‘1.0’ encoding=‘UTF-8’?><stream:stream xmlns:stream=“http://etherx.jabber.org/streams” xmlns=“jabber:client” from=“centaure.capitale.qc.ca” id=“d78e61e8” xml:lang=“en” version=“1.0”><stream:features>

<compression xmlns=“http://jabber.org/features/compress”><method>zlib</method></compression><bind xmlns=“urn:ietf:params:xml:ns:xmpp-bind”/><session xmlns=“urn:ietf:params:xml:ns:xmpp-session”/></stream:features>

<iq type=“result” id=“DN9EP-0” to=“centaure.capitale.qc.ca/d78e61e8”><bind xmlns=“urn:ietf:params:xml:ns:xmpp-bind”><jid>sdemers@centaure.capitale.qc.ca/spark</jid></bind></iq>

<iq type=“result” id=“DN9EP-1” to="sdemers@centaure.capitale.qc.ca/spark">

<session xmlns=“urn:ietf:params:xml:ns:xmpp-session”/></iq>

<iq type=“result” id=“DN9EP-2” to="sdemers@centaure.capitale.qc.ca/spark"><query xmlns=“jabber:iq:roster”><item jid="nlemay@centaure.capitale.qc.ca" name=“Normand Lemay” subscription=“both”><group>

Infocap</group></item><item jid="age06155@centaure.capitale.qc.ca" name=“Luc Gagnon” subscription=“both”><group>Infocap</group></item><item jid="denisg@centaure.capitale.qc.ca" name=“Denis Genest” subscription=“both”><group>Infocap</group></item>

<item jid="guy@centaure.capitale.qc.ca" name=“Guy Grandmont” subscription=“both”><group>Infocap</group></item></quer y></iq>

<iq type=“result” id=“DN9EP-3” from=“centaure.capitale.qc.cato="sdemers@centaure.capitale.qc.ca/spark">

<query xmlns=“http://jabber.org/protocol/disco#items”><item jid=“conference.centaure.capitale.qc.ca” name=“Public Chatrooms”/><item jid=“search.centaure.capitale.qc.ca” name=“User Search”/>

<item jid=“pubsub.centaure.capitale.qc.ca” name=“Publish-Subscribe service”/><item jid=“proxy.centaure.capitale.qc.ca” name=“Socks 5 Bytestreams Proxy”/></query></iq>

I dont have Vista so I cant say what the problem is, but thought you should be aware that you just posted your password to the fourm, and may want to edit your post so the line that says “” is removed, as this contains your password. I also suggest changing your password.

The problem occurs when uac is enable. If we disable it then not problem!

Can someody try to reproduce the bug?

David

Yes I can reproduce it.

I already tried to give every user full access to to the Program files folder of Spark, but it doesnt help.

Best regards, Maddi

Hello David

I have spark with windows Vista and it works with normal user account.

Did you installed spk 1?

Tray to disable UAC on Contral Panel, user accounts, UAC.

see ya

Denis

Hello,

well, for me it works with UAC disabled, but I think there should be a solution to work with a messenging program without disableing UAC.

As I said, I tried to give the program files folder of spark every permission, but it doesn"t help, so I think it has to do with whatever the registry entry does.

(If someone knows what it does, please write it so we maybe could figure out how to get it running on Vista)

Best regards,

Maddi

I run this fine without UAC disabled, perhaps it’s java or something requesting the permissions? Anyway, if you right click on the menu item, goto properties and compatibility, you can set it so it always runs as adminstrator, think of it as a temporary fix - try running it in compatibility mode too if you’re still having issues.

Thanks.