Need help gaining admin access to Openfire v3.4.1

I have an Openfire Jabber server (v3.4.1) here at work that belongs to me now. The previous admin did not document anything or tell me what the password was. I tried all the ones I thought it might be and none of them worked. I found a post in these forums about this, and one suggested to reset the password via the psql command line utility. I did this, and now when I visit the admin page, it wants me to fill out the entire configuration all over (which I tried to do), but when it got to the “add admins” page, all it would do is let me add admins, there was no complete or continue button to be clicked on.

So basically, I am locked out of my instance of Openfire, and how I went about changing the password didn’t work. Can anyone help? I need to be able to get into this thing, but I really don’t want to lose the current configuration.

Thanks in advance!

Hi dcapurro,

Sorry to hear about your situation. What exactly did you change in the postgres database? You should be able to discover the root account just by doing:

  1. select plainpassword from jiveuser where username = ‘admin’;


I read the post here:

The last reply suggests the following: update jiveUser set password=‘123456’, encryptedPassword = null where username =‘admin’;

I did that, and now when I go to http://172.X.X.X:9090, it takes me to the setup page and does not prompt for a password.

Your query shows the password I set from the update query I ran.


Interesting. Are your users able to log in and use the system otherwise?


Yes, users log in via AD.

You could edit your conf/openfire.xml file and set

I am not sure if you will need to restart openfire or not to make that

change stick and see if you can reach the admin console again.


<setup>true</setup> is already set.

That is weird! I am not sure what to suggest now. Can you skip the

addition of admins on the setup process and then get to the admin console?


Nope, I am not able to get past the adding admins screen. No buttons that say continue, finish, or stop.

Are you getting interesting error messages in any of the log/ files?

I checked out the error log and discovered that the daemon couldn’t write to the config file. Turns out that the files were owned by root, not by the openfire daemon. A quick chown was all that was needed, now when I went through the setup process, all of the previous settings were saved, and I was able to add myself as an admin. I wonder who chowned the cfg files, and why…?

Thanks for all the help!