powered by Jive Software

Need help with Openfire 3.5.2, Fastpath and Webchat

I have installed Openfire 3.5.2, The Fastpath plugin and I have deployed the webchat.war file to a Tomcat 5.5 server. All are operating with Sun Java 1.6.0_06.

The web chat feature seems to work fine up until the point when the Spark client actually accepts the chat request. The Spark client joins the Fastpath Conversation and the window indicates that the web chat user has also joined. However, the web chat queue information/live chat window never changes state from ‘Routing Your Request’ so the chat session is not usable.

The live chat window does show 2 javascript errors. I have attached an image of a FF3 window with Firebug that shows them, but here they are:

queue.jsp line 78: ‘room’ is not defined

room.getChatQueue(handleQueue, ‘km5omrrbnG’);

queue.jsp line 78: ‘DWREngine’ is not defined

checkQueue()

queue.jsp()

room.getChatQueue(handleQueue, ‘km5omrrbnG’);

I have noticed the same behavior with Firefox 3, IE6, IE7 and Opera 9.51.

Is there an easy fix for this that I can make locally? Have I just set something up incorrectly?

Not sure if this might help, but instead of running the webchat.war on Tomcat, try the plugin on the same server as Openfire then connect using http://server:9090/webchat and seeing if that loads. I also remember a suggstion in another thread somewhere that running webchat.war under Tomcat 6 seemed to be better.

hi…

i have a small problem with the webchat…when i make any changes in the jsp file and request that jsp,i am getting the error message as

HTTP ERROR: 500

No Java compiler available

RequestURI=/webchat/index1.jsp
Caused by:

java.lang.IllegalStateException: No Java compiler available
at org.apache.jasper.JspCompilationContext.createCompiler(JspCompilationContext.ja va:224)
at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:559)
at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:303)
at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:314)
at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:264)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1093)
at org.jivesoftware.webchat.SetCharacterEncodingFilter.doFilter(SetCharacterEncodi ngFilter.java:45)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.jivesoftware.webchat.SetupFilter.doFilter(SetupFilter.java:92)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:726)
at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollect ion.java:206)
at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
at org.mortbay.jetty.Server.handle(Server.java:324)
at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.j ava:829)
at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:514)
at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:488)

Powered by Jetty://

can anyone please help me in fixing this problem…

This does work. What is it about Tomcat 5.5 that causes the chat component to not work?

has anyone solved the problem with webchat delployed on tomcat. We are using tomcat 5.5 and see the setup-index.jsp and type in the same info as fastpath openfire plugin, which is working. the next page gives errors. I see through other discussions about tomcat6 is better.

We are using openfire 3.6.2, webchat 4.0.0 and tomcat 5.5._24. Please let me know what you have heard or how you’ve solved your problem.

What version of java are you using behind the Tomcat. Over the past week I had installed Red5 and it required Java 1.6, so I moved everything over, including my Tomcat6. My Fastpath stopped working and gave tons of java errors. Change it back to Java 1.5 and Fastpath works, but Red5 won’t. I haven’t found a workaround, but know Fastpath queues have some sort of issue going on with Java 1.6. Or maybe it’s just me… Maybe this is also what you’re experiencing?

we are using java 1.6_10. with apache tomcat 5.5_24. Thank you for informing me with red5. I too are trying to install red5 as a standalone and having problems. I am not talking about the red5 plugin for openfire but red5 (osflash.org/red5).

I have been doing some searching and it looks like a few of us in the same boat.

Our goal is to have fastpath using a secure connection with CA trusted signed certificate. We tried with secure openfire port but Openfire member advise me and plus in readme.html file it was advice to use tomcat or another software for production purposes. Getting no where but keep trying.

As for red5 standalone, I have been talking to nabble.com, red5 - users forum and and a few other forums.

thnak you for your quick response and let me know if you find anything. I will keep you posted.