powered by Jive Software

Need help with Wildfire 2.5.0 server on Win 2K

Hello all,

I have been trying to find help in these forums and around the web but sadly couldnt find anything.

I am a newbie to Jabber, so please bare with me. I am trying to setup up a Wildfire server and cannot seem to get it to work. My client is Gaim and I have tried Exodus but both seem to fail to authenticate to the server from a WinXP system. I can get to my administrator console from my client and an ping the server.

I have not changed anything from the server’'s default settings after install. Everytime I try to loggin from the client I get a failed authentication. What am I doing wrong? I am not running a firewall or antivirus, this is a VMWare environment for testing purposes.

Below is the warning logs:

2006.02.28 11:37:43 SaslException

javax.security.sasl.SaslException: DIGEST-MD5: IO error acquiring password Caused by java.io.IOException: org.jivesoftware.wildfire.user.UserNotFoundException: Test2

at com.sun.security.sasl.digest.DigestMD5Server.validateClientResponse(Unknown Source)

at com.sun.security.sasl.digest.DigestMD5Server.evaluateResponse(Unknown Source)

at org.jivesoftware.wildfire.net.SASLAuthentication.doHandshake(SASLAuthentication .java:199)

at org.jivesoftware.wildfire.net.SocketReader.authenticateClient(SocketReader.java :315)

at org.jivesoftware.wildfire.net.SocketReader.readStream(SocketReader.java:276)

at org.jivesoftware.wildfire.net.SocketReader.run(SocketReader.java:119)

at java.lang.Thread.run(Unknown Source)

Caused by: java.io.IOException: org.jivesoftware.wildfire.user.UserNotFoundException: Test2

at org.jivesoftware.wildfire.net.XMPPCallbackHandler.handle(XMPPCallbackHandler.ja va:69)

… 7 more

Below is the debug log:

2006.02.28 11:37:42 Connect Socket[addr=/192.168.213.138,port=1226,localport=5222]

Nothing in Error nor Info logs.

Any help would be appreciated. Thanks in advance.

Forgot to mention. I can also register users from the Gaim/ Exodus client.

Thanks again.

Hi,

http://www.jivesoftware.org/community/thread.jspa?threadID=18332 describes a similar stack trace.

Maybe the last nightly build could also help you.

LG

Thanks LG.

I tried a different client, Spark and exodus (again), they both worked. Exodus actually spit out a warning indicating that the certificate does not match blah blah blah. So, I found the thread on that and created my own cert. Now the error is gone and everything works fine and dandy with Spark and Exodus.

Still having problems with Gaim.

These are the errors, Im getting now:

2006.02.28 17:40:06 [org.jivesoftware.wildfire.net.SocketReader.negotiateTLS(SocketReader.java:680)

] Error while negotiating TLS

javax.net.ssl.SSLHandshakeException: no cipher suites in common

at com.sun.net.ssl.internal.ssl.Handshaker.checkThrown(Unknown Source)

at com.sun.net.ssl.internal.ssl.SSLEngineImpl.checkTaskThrown(Unknown Source)

at com.sun.net.ssl.internal.ssl.SSLEngineImpl.writeAppRecord(Unknown Source)

at com.sun.net.ssl.internal.ssl.SSLEngineImpl.wrap(Unknown Source)

at javax.net.ssl.SSLEngine.wrap(Unknown Source)

at org.jivesoftware.wildfire.net.TLSStreamHandler.doHandshake(TLSStreamHandler.jav a:320)

at org.jivesoftware.wildfire.net.TLSStreamHandler.(TLSStreamHandler.java:206)

at org.jivesoftware.wildfire.net.SocketConnection.startTLS(SocketConnection.java:1 50)

at org.jivesoftware.wildfire.net.SocketReader.negotiateTLS(SocketReader.java:677)

at org.jivesoftware.wildfire.net.SocketReader.readStream(SocketReader.java:266)

at org.jivesoftware.wildfire.net.SocketReader.run(SocketReader.java:119)

at java.lang.Thread.run(Unknown Source)

Caused by: javax.net.ssl.SSLHandshakeException: no cipher suites in common

at com.sun.net.ssl.internal.ssl.Alerts.getSSLException(Unknown Source)

at com.sun.net.ssl.internal.ssl.SSLEngineImpl.fatal(Unknown Source)

at com.sun.net.ssl.internal.ssl.Handshaker.fatalSE(Unknown Source)

at com.sun.net.ssl.internal.ssl.Handshaker.fatalSE(Unknown Source)

at com.sun.net.ssl.internal.ssl.ServerHandshaker.chooseCipherSuite(Unknown Source)

at com.sun.net.ssl.internal.ssl.ServerHandshaker.clientHello(Unknown Source)

at com.sun.net.ssl.internal.ssl.ServerHandshaker.processMessage(Unknown Source)

at com.sun.net.ssl.internal.ssl.Handshaker.processLoop(Unknown Source)

at com.sun.net.ssl.internal.ssl.Handshaker$1.run(Unknown Source)

at java.security.AccessController.doPrivileged(Native Method)

at com.sun.net.ssl.internal.ssl.Handshaker$DelegatedTask.run(Unknown Source)

at org.jivesoftware.wildfire.net.TLSStreamHandler.doTasks(TLSStreamHandler.java:37 1)

at org.jivesoftware.wildfire.net.TLSStreamHandler.doHandshake(TLSStreamHandler.jav a:281)

… 6 more

2006.02.28 17:40:06 [org.jivesoftware.wildfire.net.SocketReader.run(SocketReader.java:159)

] Connection closed before session established

Socket[addr=/192.168.213.138,port=1317,localport=5222]

Nothing much in the other logs. If anyone can point me in the right direction it would be greatly appreciated.

Thanks

Hi STimps

What kind of OS enviroment do you have? Why do you want multiple clients? Letting user decide which clients to choose and having multiple clients will come back to haunt you when it comes to support. Just my opinion.

Regards,

wmhtet

check the post again and find that you are still testing the server. anyway, I still advice what I advice.

Message was edited by: wmhtet

Thanks for the response and help.

I figured out what was the problem and I am able to run GAIM with my Wildfire server now. I had to add a new RSA cert to the Keystore.

This is the thread where I found the solution.

http://www.jivesoftware.org/community/thread.jspa?messageID=98962&#98962

Stimps