powered by Jive Software

Need the older version of User Service that runs on the 3.1

Hi,

Bad luck, I have updated all the plugins installed on my 3.1 server without viewing the Changelog and now I’‘ve discovered they don’'t work anymore becuase they require OpenFire 3.3. The most critic for me is User Service, So people who will subscribe to my website will not have their Wildfire accounts created and will not be able to chat And you guessed it, I will not do that manually!

Usually “upgrading” or “updating” rarely blocks older versions from working correctly guys, sorry but you should have treated this change differently. I mean it is critic change! Someone who sees there is an update, the last thing he will think about is it will prevent his current installation from working correctly. Why proceeding to the update if the required server version is not present ?? I really don’'t understand!

Ok now I cannot rewind what I did, but is there a way to find back the older version of User Service and install it manually ??

pleaaaaaase, is there a way to get the previous version of User Service ? the one that runs on the 3.1.1

Hey hbr,

Have you tried getting them from http://www.igniterealtime.org/projects/wildfire/plugins.jsp ? There you will find the user service plugin that required Wildfire 3.1.0 or later (but older than Openfire 3.3.0).

Regards,

– Gato

Hey,

Thanks for that link I didn’'t know it.

It still doesn’‘t work though, here is what I did, correct me if I’'m wrong:

  • I’'ve stopped wildfire

  • removed the userservice & userservice.jar from the plugin folder

  • copied the userservice.jar version 1.1.1 I downloaded

  • restarted wildfire

In the admin console under the Plugins tab, it automatically detects the plugin, and I have 3 options :

  • restart the plugin

  • upgrade to 1.2 (and therefore OF3.3)

  • remove

In all those cases, it automatically gets the 1.2 version, which requires the OF3.3

In the Available Plugins tab, the User Service is still visible but without the Install icon. Neither before nor after I copy the 1.1.1 manually and restart Wildfire.

Forget what I said in my last post :d

It reappeared in the list and seems to be okay.

I’'ll test it and close the thread if it is okay

Thanks a lot!