powered by Jive Software

Need to make may assistant an adminsitrator too

I set up OpenFire and Spark several months ago and its worked great. Now I want to add my assistant as an administrator so he can log into the web console.

It’s running on a Windows 2008 server. We have integrated Active Directory into it.

There should be an easy way to do this but after search every single setting in the Open Fire web console I can’t see any way to do this. I’ve searched through community here but haven’t found anything to help me.

Are you looking for admin.authorizedJIDs?

“Server”, “Server Manager”, “System Properties” should show you the current administrors, for example:

admin.authorizedJIDs = guest@example.com,admin@example.com

Make a database backup before you modify these settings! If something goes wrong there will be no admin.

So I click Edit for admin.authorizedJIDs. I see in the Property Value field: theresa@s14

So to add my assistant, do I need to put a comma or semi-colon and add his name? Or do I put a return after my name and add his name?

Also, the “@s14” is confusing to me. S14 is the name of the server. Do I add Jerry@S14 ??

Duh. I see that you put a comma there. I’ll give it a try.

A comma is fine.

Is “s14” really your xmpp.domain? This would be quite a short one for internal-only use.

No. S14 is the name of the server.

http://community.igniterealtime.org/docs/DOC-1061 is the reference document. Actually this should not work using the server name.

I tried:

jerry - didn’t work

jerry@domainname didn’t work

jerry@s14 worked!

For some reason his and my names work if we append @ and the server name at the end.

Weird.