powered by Jive Software

New 2.1 server can''t connect through client

Hello,

I just set up a new server using the 2.1.0 beta on my Windows 2003 Server. I got it installed and can use the Admin Console, but can’'t connect through my client. It gives me an error when it starts up when I look at the log.

2005.01.12 13:01:00 [org.jivesoftware.messenger.net.SocketAcceptThread.run(SocketAcceptThread.java: 132)

] Could not setup a server socket

java.net.BindException: Address already in use: JVM_Bind

at java.net.PlainSocketImpl.socketBind(Native Method)

at java.net.PlainSocketImpl.bind(Unknown Source)

at java.net.ServerSocket.bind(Unknown Source)

at java.net.ServerSocket.(Unknown Source)

at org.jivesoftware.messenger.net.SocketAcceptThread.run(SocketAcceptThread.java:1 11)

I’‘m assuming it’'s related. Anyone have any ideas?

Nathan

What client? Are you running the client from the same machine as the server? If not, are your 5222/5223(ssl) ports blocked?

The client I am using is Psi. I’'m running it from a different machine on a different network. I am connected to another jabber server using Psi on this machine and I know the port 5222 is allowed through our firewall.

As far as I can see there isn’'t any type of firewall on my 2003 server. The windows firewall is disabled.

Nathan

By no means I’'m no expert but this looks to be the problem?

"] Could not setup a server socket

java.net.BindException: Address already in use: JVM_Bind"

Another service or app that you’'re running may not be letting you connect to the server? have you restarted your server? Do you have another copy of jive running? where you able to run a different version of jive before?

Yeah, I saw those messages so I’‘m pretty sure that’‘s what’‘s causing it. But I don’‘t know what the conflict is. I don’‘t have another Jive on the server. I wasn’'t running any version of Jive before this one. I have reboot the server several times.

Here is a dump of netstat

Active Connections

Proto Local Address Foreign Address State

TCP 0.0.0.0:25 0.0.0.0:0 LISTENING

TCP 0.0.0.0:42 0.0.0.0:0 LISTENING

TCP 0.0.0.0:53 0.0.0.0:0 LISTENING

TCP 0.0.0.0:80 0.0.0.0:0 LISTENING

TCP 0.0.0.0:110 0.0.0.0:0 LISTENING

TCP 0.0.0.0:135 0.0.0.0:0 LISTENING

TCP 0.0.0.0:143 0.0.0.0:0 LISTENING

TCP 0.0.0.0:366 0.0.0.0:0 LISTENING

TCP 0.0.0.0:445 0.0.0.0:0 LISTENING

TCP 0.0.0.0:554 0.0.0.0:0 LISTENING

TCP 0.0.0.0:1025 0.0.0.0:0 LISTENING

TCP 0.0.0.0:1026 0.0.0.0:0 LISTENING

TCP 0.0.0.0:1027 0.0.0.0:0 LISTENING

TCP 0.0.0.0:1030 0.0.0.0:0 LISTENING

TCP 0.0.0.0:1032 0.0.0.0:0 LISTENING

TCP 0.0.0.0:1040 0.0.0.0:0 LISTENING

TCP 0.0.0.0:1433 0.0.0.0:0 LISTENING

TCP 0.0.0.0:1755 0.0.0.0:0 LISTENING

TCP 0.0.0.0:3306 0.0.0.0:0 LISTENING

TCP 0.0.0.0:3389 0.0.0.0:0 LISTENING

TCP 0.0.0.0:4369 0.0.0.0:0 LISTENING

TCP 0.0.0.0:5222 0.0.0.0:0 LISTENING

TCP 0.0.0.0:5223 0.0.0.0:0 LISTENING

TCP 0.0.0.0:5269 0.0.0.0:0 LISTENING

TCP 0.0.0.0:5280 0.0.0.0:0 LISTENING

TCP 0.0.0.0:5800 0.0.0.0:0 LISTENING

TCP 0.0.0.0:5900 0.0.0.0:0 LISTENING

TCP 0.0.0.0:9090 0.0.0.0:0 LISTENING

TCP 0.0.0.0:9233 0.0.0.0:0 LISTENING

TCP 0.0.0.0:52111 0.0.0.0:0 LISTENING

TCP 10.15.15.193:21 0.0.0.0:0 LISTENING

TCP 10.15.15.193:139 0.0.0.0:0 LISTENING

TCP 67.50.48.148:21 0.0.0.0:0 LISTENING

TCP 67.50.48.148:139 0.0.0.0:0 LISTENING

TCP 67.50.48.148:139 64.221.224.227:6337 ESTABLISHED

TCP 67.50.48.148:445 67.50.151.17:3269 ESTABLISHED

TCP 67.50.48.148:1049 67.50.48.148:1433 ESTABLISHED

TCP 67.50.48.148:1050 67.50.48.148:1433 ESTABLISHED

TCP 67.50.48.148:1051 67.50.48.148:1433 ESTABLISHED

TCP 67.50.48.148:1052 67.50.48.148:1433 ESTABLISHED

TCP 67.50.48.148:1053 67.50.48.148:1433 ESTABLISHED

TCP 67.50.48.148:1433 64.221.224.227:64666 ESTABLISHED

TCP 67.50.48.148:1433 67.50.48.148:1049 ESTABLISHED

TCP 67.50.48.148:1433 67.50.48.148:1050 ESTABLISHED

TCP 67.50.48.148:1433 67.50.48.148:1051 ESTABLISHED

TCP 67.50.48.148:1433 67.50.48.148:1052 ESTABLISHED

TCP 67.50.48.148:1433 67.50.48.148:1053 ESTABLISHED

TCP 67.50.48.148:3389 64.221.224.227:6318 ESTABLISHED

TCP 127.0.0.1:21 0.0.0.0:0 LISTENING

TCP 127.0.0.1:1034 127.0.0.1:4369 ESTABLISHED

TCP 127.0.0.1:1035 127.0.0.1:1036 ESTABLISHED

TCP 127.0.0.1:1036 127.0.0.1:1035 ESTABLISHED

TCP 127.0.0.1:1037 0.0.0.0:0 LISTENING

TCP 127.0.0.1:4369 127.0.0.1:1034 ESTABLISHED

UDP 0.0.0.0:42 :

UDP 0.0.0.0:445 :

UDP 0.0.0.0:500 :

UDP 0.0.0.0:1029 :

UDP 0.0.0.0:1041 :

UDP 0.0.0.0:1434 :

UDP 0.0.0.0:1755 :

UDP 0.0.0.0:4500 :

UDP 0.0.0.0:5353 :

UDP 10.15.15.193:53 :

UDP 10.15.15.193:123 :

UDP 10.15.15.193:137 :

UDP 10.15.15.193:138 :

UDP 67.50.48.148:53 :

UDP 67.50.48.148:123 :

UDP 67.50.48.148:137 :

UDP 67.50.48.148:138 :

UDP 127.0.0.1:53 :

UDP 127.0.0.1:123 :

UDP 127.0.0.1:1028 :

UDP 127.0.0.1:1039 :

I don’‘t see ports 111 or 132 if that’'s what the error is indicating.

Feel try to try to connect to it.

thinktheweb.com is the domain. It has open registrations right now.

Nathan

Ok, I figured it out. Aparantly previously I had started setting up an ejabberd server and the service for it was still running. I downloaded TCPView and it showed it. Once I stopped that service and stopped/started the jive again everything worked just fine.

Thanks for your help.

Jive Messenger will use the following ports by default:

5222: standard XMPP

5223: SSL XMPP

9090: admin console

Is it possible you have a service running on 9090? If so, you can change that port by modifying jive_messenger.xml in the conf dir.

Regards,

Matt

I was able to connect via Exodus (last version) and created a user “carlos” same thing with PSi (0.9.3)user “carlos2”

Nathan,

Don’'t forget to award out any any “helpful” or “correct” answers.

-Matt

Glad to hear that it’'s working!

Now if only there were some transports